Unable to switch off altitude offset easily when using Garmin Glo external GPS?

Pascal Quantin shared this problem 1 week ago
Solved

Hi,

I just bought a Garmin Glo external GPS bluetooth receiver and I'm so far happy of its support in Locus Map. But I just noticed that the altitude reported by Locus seems to apply an altitude offset, despite not having the "enable also for Bluetooth GPS" box checked (checking/unchecking the box does not change anything, it's like if it was always applied). Switching between automatic correction and NMEA correction does not change anything either.So each time I connect it, I must unselect the altitude offset option (and reactivate it when I use the internal GPS), which is quite painful. If this a known issue?

Thanks for your great product,

Pascal.

Comments (5)

photo
1

Hi Pascal,

I'm not sure if this can be called an "issue" - your device just respects general Locus settings. The option "enable also for Bluetooth GPS" is rather dedicated to devices that don't respect it.

photo
1

Hi Michal,

according to http://help.locusmap.eu/topic/no-altitude-correction-with-external-bt-gps-receiver and http://docs.locusmap.eu/doku.php?id=manual:user_guide:tools:altitude&utm_source=application&utm_medium=Locus%20Map%20Pro, my understanding is that altitude correction should not be applied to external bluetooth GPS receiver, unless the Enable also for Bluetooth GPS option is checked (which is not the case for me). So I do not understand why you say this option shoudl be dedicated to device that do not respect the general setting (and toggling it does not change anything).

Best regards,

Pascal.

photo
1

By the way as this is the first itme I use this site, I see that I created the topic has a question while I *think* it should be classified as a problem (at least per my understanding, waiting for your feedback). Not sure if this can be changed afterwards or not.

Thanks,

Pascal.

photo
1

Hi Pascal,

you were right - there was a bug. We found it and fixed it. The change will come into effect in the next coming version. Thanks!

photo
1

Hi Michal,

great ! Thanks a lot for the fast fix.


Pascal.