Audio Coach reports the time a few seconds late?

Taras D shared this problem 19 months ago
Solved

This might not be a problem but only something I never noticed before!


I am using Locus Map Pro V3.22 and I have the Audio Coach reporting the elapsed time every 15 minutes. Here is what Audio Coach reported over a period of one hour.

  • 15 minutes and 0 seconds
  • 30 minutes and 8 seconds
  • 45 minutes and 6 seconds
  • 1 hour and 0 minutes

I am almost positive that prior to V3.22, it would always report the time precisely every 15 minutes. I've only used the Audio Coach twice and both times it reported the 30 and 45-minute intervals a few seconds late. I don't remember this behavior in the previous version(s).

Is it possible the older version(s) didn't report the seconds? (Or always reported 0 seconds?)

Comments (5)

photo
1

Good day Taras,


I noticed similar un-precise values also during testing, but to be true, I was little lazy to deal with it :). Well, system improved and these issues should be fixed in next version. Thank you for small "kick".

photo
1

I tested Locus Map V3.22.2 and the first 15-minute interval was reported as "14 minutes and 59 seconds". All other intervals, from 30 minutes to 1 hour and 15 minutes) were reported correctly.

I will test it again today and let you know if the first interval is reported correctly or not.

photo
1

I regret to inform you that the problem is repeatable. I used the Audio Coach a second time and it reported the 15-minute interval as "14 minutes and 59 seconds". All other 15-minute intervals were reported corrected.

photo
1

Hello Taras,

thanks for a testing. Unfortunately I'm unable to simulate same problem on own device. I think it may be some problem with rounding of computed values, so I've improved this little bit, so we will see in next version ...


Anyway main problem is solved now, so this is just minor remaining issue.

photo
1

Good new! I used the Audio Coach two more times and it always reported "15 minutes".

I made one change that seems to have fixed the problem ... but it may just be a coincidence. Before starting a track-recording (using the side-menu) I switched "Training Auto-Start" -> "Walking" to "Disabled". Then I changed it back to "Walking". I only did this once and now Audio Coach always correctly says "15 minutes" (and not "14 minutes and 59 seconds"). I can't be certain that "toggling" the training scheme is responsible for the correction ... but I'm glad it speaks the time properly now.