Automatic Keyboard pop up in Geocache login

Patrik Sistik shared this problem 4 months ago
Closed

Since the new improvements for Geocaching arrived I have found one thing that is bothering me. Once I press "Log visit", the Logging screens pops out together with the cursor directly in the comment, which triggers automatic keyboard pop up (as per screen below) and the "Confirm" button is therefore hidden.


For many active users this could be an issue, as we usually log offline (creating just emtpy fieldnotes with "smileys". Now I need to press the Back button for the Keyboard to dissapear first, to be able to "Confirm" the log. So, this is an extra click to be done for logging compared to previous versions.


It seems as a small issue, but for me, as I usually find about 40-50 caches each trip, this is rather bothering. Is there anything you can do, to proceed with the logging as in the previous versions? (so the cursor is not blinking in the Comment sections & the Keyboard is not visible = meaning the "confirm" button is not hidden below the keyboard?


Thanks

Comments (7)

photo
1

It's OK for me.

The button is dynamic and moves above the keyboard.

photo
1

That is exactly what I was used to. But from the last major update it does not work for me.

Xiaomi Mi A1, Android 8.0, Locus 3.31.1

photo
1

Hmm, hi Patrik, Condor,

maybe enabled "Full-screen mode" has influence here?

Also in your case, I see you have an empty description that is not allowed, so you have to click into the description to write at least something ...

Jiří M. aka Menion

photo
1

Yes. The reason is the full screen.

Text or empty does not effect.

photo
1

confirmed. its the full screen. Thanks god I do not have to write anything into field note comment :) I prefer logging from home.


Thank you guys, I can live with fullscreen off.

photo
1

Thanks Patrik,

I'm sorry, full-screen more is immediately after GPS on Huawei devices my biggest nightmare and current solution is probably best I can do for now. Exactly this problem is already many years reported on Google bug-reporting web site, but till now, no change. Thanks for understanding.

photo
1

Nightmare nr 1. Huaaaweeeiiiiiii !


You noticed the comment ?

http://help.locusmap.eu/topic/screen-dim-instead-of-power-off#comment-58505


Normal mode:

Screen off: Lum: 0%. (By backlight off = touch screen off)

Screen on: Lum: to 100% (Lum by backlight)


I realise suggestion is a very (ugly) workaround but oh well it is ugly (phone) feature.

= Like the newest chinese car technology energy saving modus. Save petrol, go out and push.


Huawei mode: Screen off: Lum >> + 0 %: (1 to 100%)

By min (no root) % backlight + xx % transparant 'curtain'.


Full screen cover by xx% transparant curtain (INACTIVE touch button).

- Prevent accidental touches phone in pocket.

- Prevent action trigger by raindrop touches.


Wake up methods.

1. Switch on/off by the proximity gesture (single_double wave) sensor.

config.cfg

# Disable "Turn off if idle" when screen was turn on by gesture (default: false)

turn_on_screen_by_gesture_disable_auto_screen_off=1

2. other ?

Sweet dreams !

photo