Distinct symbols for map items

Bucky Kid shared this problem 22 days ago
Solved

Good afternoon, I wish to make clear if and how symbols in map items GPX format are handled.

I add the locus format specification


  <extensions>
     <locus:icon>file:POI.CZ.zip:bouda_m_2_4_1.png</locus:icon>
  </extensions>
  <sym>bouda_m_2_4_1</sym>
This is ignored and Locus uses generic (i) symbol instead. My question is: do I need to adjust the attribute so Locus takes the icon into account? (provided the icon reference is valid)

Comments (6)

photo
1

Hi,

could you please share the file here for testing?

photo
1

Hi, file for testing.

Files: test.zip
photo
2

Hello Bucky Kid,

It took me a while to find out the real reason. In file are used "sym" and "locus:icon" tags together and unfortunately "sym" always overwrote "locus:icon" value.

An issue on our side ... will be fixed in next 3.34 version, thanks.

EDIT:

just warning, file is full of "icons", that does not exists, like 2_1_0, 2_2_0 etc.

/944c6120f85317d6a16b514673f2a1bc

photo
1

Hello menion. The distinct symbol worked in Locus 3.33.2 after removing the <sym>....</sym> attribute.

Not working in Locus 3.34 :(

My POI file not showing custom icons and related icons library in attachment

Can you please explain what's the meaning of <sym> attribute, does it affect the POI appearance or is it completely ignored now?


Nevermind, mapitems show icon good.

The problem is by custom icons of waypoints from database.

Files: test.zip
photo
1

So not, some POIs from map items file show can't show custom icon too, though the icon is present in external icon library.

Custom icon references are broken in db and map items.

photo
1

Do not waste time on this issue today Bucky,

problem will be based on this: http://help.locusmap.eu/topic/problem-with-custum-icon-pack

Fix I made because of this problem had small side effect and this is most probably result. Sorry