Export GPX of Track: formatted description of Waypoints by mistake

sonny shared this problem 2 months ago
Solved

Since about 2 or 3 weeks, the GPX export of a track includes formatted descriptions at the extra Waypoints (but not the track or the trackpoints) by mistake. Although I didn't check the option "Insert formated descriptions" within the GPX export dialog. The problem is the same for GPX v1.0 and v1.1

Please remove this formated description of a track's Waypoints since this causes problems when displaying the Waypoints in another software like JOSM for editing OpenStreetMap using my track. (Much Html code instead of Name of the Waypoint only)

Comments (8)

photo
1

+1

Here's how the problem appears in JOSM. The point's formatted description appears even though I did not request the option when exporting the track in Locus. The two points shown in the image were created "in-track" using V3.23.1:

http://docs.locusmap.eu/doku.php?id=manual:user_guide:points:add#track_recording

123ed5c46b2d4535068991a4639bf29a

photo
1

Hi this issue has been solved a few days ago - check latest Beta version.

photo
1

I think the problem may have returned in V3.24.1.

I recorded a track on May 28 using Locus Map V3.23. Today I exported it (GPX) using Locus Map V3.24.1 and imported it into JOSM. The point's HTML description is still displayed (see example below).

1bb35a8dd6db438dc40062f8184889a8

photo
1

Issue is in stored data so tracks recorded with previous version may have a problem. Please try new tracks recorded with latest version. It should be OK.

photo
1

Confirmed! Freshly recorded track with points in V3.24.1 does not have the problem.

photo
1

<edit>: sorry made a comment by mistake.

photo
1

No problem. So all is fine with latest version? Thanks sonny, I started to worry that issue is still there when I read email notification. Uff

photo
1

I had option "insert formated description" active by mistake in GPX-export dialog of track ;-)

Now i swiched checkbox off and hope no more HTML-code is inserted.

photo