Export to OSM. Login in to OSM isn't working

ivo Nörenberg shared this problem 4 months ago
Solved

I tried to export a track to OSM. I got an error message. I cleared the Login and re-entered my login details. Still can't login. I tried "Forgotten Password". I get message "Could not find that email address, sorry". But I can still login into my OSM account in my browser. No error message at all. Whats wrong?

Comments (18)

photo
1

Good day ivo,

interesting, just tried and no problem. Aren't you using any special characters in your name/pass? I expect it was working before right? These problems come with this new version?

photo
1

Not in my Login Name or Email address. Yes it was working before but I don't know which version

photo
1

When you login to OSM in Locus Map, app opens a screen where you enter name and password. This screen looks like some kind of web browser, right? At least it should work like that. This screen is anyway on 100% in hands of Openstreetmap.org web server, not in Locus Map. So also an error message comes from this server.

Maybe two months ago, they little changed method how app login. Are you using latest Locus Map version, which should be working correctly here?

photo
1

I use 3.32.0. Yes looks like webpage. Very strange. I can login on the same phone with chrome browser.

I also can't log in with google account


403. That’s an error.


Error: disallowed_useragent


This user-agent is not permitted to make an OAuth authorization request to Google as it is classified as an embedded user-agent

photo
1

Hmm that completely different story. I did not notice that it is possible to use Google as login system.

In this case, it cannot work. It will need quite a big change in app I'm worried.

So for now, it is necessary to use any other method than Google, in ideal case email and password ... which does not work, I know.

Sorry, I have absolutely no idea how may I now help here. I'm adding this as a task on later. Change of login system that supports new Google system may also solve the issue with name/pass login. Till then, you will have to use manual upload of tracks on web. Thanks for understanding.

Menion

photo
1

Hello ivo,

I think I have found an issue. So in next version ...

EDIT: I've not also created login over external web browser, so also Google system will be working.

Menion

photo
1

I still can't login with my email or with my google account.

photo
1

After update 3.32.2


When I click: export - OSM - login : error message unsupported file format http://www.google.com


I am not even asked to enter my password.

photo
1

Weird problem. Do you have any web browser enabled in your system? Maybe you may try to install Chrome from Google Play if this helps. Anyway even a stock web browser should work here.

photo
1

I use chrome as standard web browser on my phone. I can login to OSM from chrome browser

photo
1

ivo, if possible, try to login over email/pass.

I'm testing it and after tap on login, Chrome opens and I see login options. At bottom after tap on Google, appears system dialog who should continue with this task where is Chrome and also Locus. Here anyway is necessary to choose a Chrome browser! May you try it? After login, reopen of Locus Map should be done automatically.

photo
1

After I hit login its says "working" and then "unsupported file format http://www.google.com"

I am not asked for anything. I have no choice to do anything else. No email/pass option anymore.

photo
1

Hmm may you please give it one more try?

Open system settings > apps > Locus Map > and "Clear defaults". Maybe Locus Map tries to handle result of operation that should be delivered into chrome.

photo
1

same result

photo
1

ivo, I'm little lost with this issue. Based on your error, I found single possible place where this happen. It seems that your Chrome simply redirect to Locus Map result, that belongs to Chrome itself and not to Locus. Why, do not know.

If you don't mind, should you clear cache and data of the Chrome browser? I really do not understand why this happen, but it looks to me more like problem somewhere out of Locus Map app. Thanks and sorry for complication.

photo
photo
1

Now is it ok

photo
1

upload to OSM goes. but if I want to report a map error, the login will not work

photo
1

If you get error 400 after report a new note, this will be fixed in next version, thanks.

photo