Flashing screen in landscape mode with ICS

Kaj shared this problem 6 years ago
Solved

After upgrading my SGS2 to ICS (official Android 4.0.3) I got problems with the latest Locus Pro 2.1.1. (and also the previous version). When starting Locus Pro in landscape mode (or entering landscape mode by tilting the phone after starting in portrait mode) the whole screen starts flashing/blinking intensely several times per second. The responsiveness of push buttons on the screen is limited and the only way to solve this is by forcing shut down in the task manager and restart Locus. Running only in portrait mode seems to work.


I also tried Locus Free 1.5.1 and this version works fine.

Comments (5)

photo
0

Kaj,


may you please do for me by Locus Backup manager just backup of your settings (file will be stored in Locus/backup if you don`t know this) and send me it? It also happen to me some long time ago but since then, no problem. When I try it now, also no problem so I think, it should be effect of some settings. Thanks

photo
0

"Unfortunately" I uninstalled Locus Pro and then reinstalled it again. After that the problem disappeared, so it may have been some setting which was changed when I did the upgrade from Android 2.3.3 to ICS (while keeping the old installation of Locus). Just upgrading from Locus pro 2.1.0 to 2.1.1 did not solve the problem. I had to remove the program completely before reinstalling it again.


Anyway now it works fine.


Thanks for the response and thankyou for a great program. I like it a lot

photo
0

Ah damn ... thanks for email. In logs is nicely seen that it still in cycle call basic "onCreate()" function so it still recreate whole main screen. I never happen to me no matter if I import your settings or with my own. Now you write it also don`t happen to you.


So I`m closing this topic but problem is not "solved" but just delayed. If it occur again, reopen it here and I`ll try to solve it!

photo
0

finally found source of troubles.


Fix applied on new version. Those with this issue (it happen when you select different then default language in locus and rotate screen), test next Play release (probably tomorrow)

photo
0

Unfortunately this problem still exists with Locus Pro 2.8.2 on my Nexus 7 with Android 4.2.1. If I reset the preferences I have no problems but as soon as I restore a backup or just the settings the screen starts blinking after an orientation change.


I just found out that the Locus user interface language setting seems to be the problem. English is making trouble but German works fine (Android itself is configured to use German).