Gaps in recording

Gordon Nudd shared this question 3 months ago
Answered

When recording sometimes there is no red line behind the marker, and the recording will show at this point just a straight line. This is to be expected when satellites are not being recieved. However this also occurs when the marker on the screen follows the route exactly, ie when satellites are being recieved! The app galileo, running at the same time, records the path correctly with no gaps. In the enclosed image the marker followed the track exactly, but no red line or recording.

Comments (13)

photo
1

Hi Gordon,

this behavior is most probably caused by your device battery optimization that interrupts track recording running in the background. Exclude Locus Map from this optimization or turn the optimization off. More info here: http://docs.locusmap.eu/doku.php?id=manual:faq:gps_lost_fix_android6

photo
1

Thanks, but I have all power saving modes off anyway.

photo
1

What type of phone and Android version do you use?

photo
1

I can confirm this problem. It happens rarely... but it does... maybe once every few days. For me, it happens after having a little break (phone not moving) and then start cycling again. Sometimes Locus will simply not continue track recording in these occasions.


This bug has been there for years... if I remember correctly it was related to a "only record while moving" setting in Locus. I thought it had been fixed long ago, and maybe it was, but apparently not completely.


Just an idea... my issue sounds a bit like the same problem as Gordons.

photo
1

Samsung Note 4 and Android 6

photo
1

OK then let's have a look at your settings.

1) Go to Locus settings > GPS&location > Disable when hidden - ON or OFF?, Track recording - ON or OFF?, GPS auto off - ON or OFF?

2) Locus settings > Track recording > choose the recording profile the issue appears on > profile settings > Required accuracy (what value?), Record only when moving - ON or OFF?

photo
1

Disable when hidden - OFF

Track Recording - OFF ( I guess this could be ON, however the track recording isn't paused and the screen was on - I saw the marker follow the exact track)

GPS Auto off - OFF

Track Recording Foot 5m 3s 10m

Record only when moving - haven't found this

photo
2

Have just found under track recording 'System battery optimization enabled' - although all optimization is turned off! I will try truning this off next time.

photo
1

just goes to battery optimization page where everything is turned off anyway

photo
photo
1

Hi Gordon,

you have set 10m accuracy for track recording - that's too little - therefore, Locus doesn't record trackpoints with less accurate estimated position. Increase this value to at least 30m. Your phone GPS accuracy may vary esp. in worse terrain/weather conditions behind your 10m limit.

photo
1

ich werde es ausprobieren, danke!

photo
1

Hello.-----------------

Maybe the problem arises when during an hour or two user does not check Locus

and then takes a photo?

-----------------


The problem happened to me today during biking.


The problem has persisted for years.

I had the same problem on my previous Sony Xperia Arc S, Android 4.

I have it on my current Huawei Honor 7.

Due to the problem with recordings I started use Orux Maps - there I noticed no problem.


My current settings:


Phone Honor 7 PLK-L01

Android 5.0.2

EMUI 3.1

Locus Map Free, version 3.29.2

Camera (Huawei), version 5.0.2


Locus Map is within "Protected apps", which means apps keep running after the screen is turned off.

"Protected apps" settings work correctly for other apps, like widgets for SHMUapp (it always stopped before it was included into the "protected apps".)


The events:

10:00 am - Track recording started

- Several photos taken during track recording, Locus works ok.

1:43 pm - I checked Locus, it worked ok. Probably this is the last time I checked Locus.

3:19 pm - I had a break in my biking, did not open the screen.

Locus several times beeped, telling that he lost and found satellite signal.

3:51 pm - I resumed my biking, Locus was recording track.

4:30 pm - Track point 2360, speed 18,3 km/h

4:30 pm - Track point 2361, speed 18,0 km/h

4:30 pm - Track point 2362, speed 18,5 km/h - THE LAST POINT ON THE TRACK

4:xx pm - Stopped my bike

4:34 pm - Photo taken

4:34 pm - Photo taken

4:36 pm - Photo taken

Continued biking.

Expected Locus to measure on. But no new track point was recorded.

photo
1

Hi,

gaps in track recording are generally caused by the device battery optimization, especially Honors have this system very agressive. If no measures excluding Locus from the system help, try Locus settings > Gps&location > Google Services assisted location > ON (Google Service must have location options enabled and permitted in system).