GPS can't start after unlocking phone

Dmitry Lesev shared this problem 1 month ago
Solved

Hi

I've set next GPS & Location settings:

"Run as startup" - always

"Disable when hidden" - no

"Track recording" - yes

"GPS auto-off" - yes

"GPS update interval" 100s

"Max search time" - 60s

"Keep auto-off enabled" no

Start Locus, start track recording and lock my phone.

In 5 minutes i unlock the phone but cursor shows my last position. When i tap right top green label "GPS", Locus shows no satellites. This situation is not recovered automatically, so i have to tap "Switch off GPS", "Switch on GPS" for restarting GPS.

Today i've got it 3 times. It seems happens only if track recording is on. I'm not sure but in the previous version it was ok.

Comments (2)

photo
1

Hi Dmitry,

there might be more reasons why this happens:

1) your device uses some kind of battery optimization that switches GPS off (see http://docs.locusmap.eu/doku.php?id=manual:faq:gps_lost_fix_android6)

2) your "GPS auto-off" settings are too strict - GPS doesn't manage to get fix within the set time interval or with the set accuracy - set longer interval or wider accuracy

3) your "GPS auto-off" settings collide with settings of your recording profile - check both and set cooperating values

photo
1

Hi Michal,

yes, thank you - it was 1st variant. I don't know how it happened, because several days ago it worked well.

Mark please as solved