GPS is on when Locus is in background

Layio shared this problem 5 years ago
Solved

Hello.


On latest version and several ago I have problem with GPS activity when put Locus in background. I have turn off option to hold GPS when Locus not active, but many times this not work. When I use GPS in app, and send it background with home key, in 90% cases GPS is still active, only way to turn it off is close Locus.


Maybe this happen because of wakelocks are not correctly use by Locus?


HTC Sensation, with Android 4.1.1.

Comments (8)

photo
1

hello,


hmm this should be working correctly. Are you sure, you`re not running any feature that require GPS? Navigation, guiding, POI alert ...?

photo
1

Yes, it`s only happen when Locus is in backgroud.


Alredy Locus search for sats, I push it to background, but Locus still search sat, and there is active wakelock - GpsConnection (menion.android.locus.pro.LocusPro).


See screenshot.

photo
0

hmm I`m checking code, and it`s almost impossible not to release wakeLock ...


you put locus to background, keep it there for a while (30 sec for example) and whole time, your device search for sats right?


may you then please do menu > more > Backup manager > Backup only settings and send me your backup on locus@asamm.com email? I do not heard about some problems with GPS in Locus for a quite long time ...

photo
1

Yes, it wake lock for the whole time.

photo
1

I remember this problem happening to me as well. Only very rarely though, maybe 3 times a month.

photo
0

I can say, I also haunts me sometime. But it was so hard to recreate, that I couldn`t even find a proof. Good to see others having the same prob.

photo
1

hmm fine, so such problem exists. So please, keep your eyes open. This is something, I have to simulate it on my device, otherwise I`m unable to fix it. So when someone discover any news, I`ll gladly do something with it ...

photo
1

Hello guys, Layio mainly ... I received email from your with your settings a two weeks ago. I already tested it and forget to response here.


There is nothing unusual on your settings. I was testing this a lot ... around an hour, I was putting locus to background and back and again and again and may confirm that in some rare cases this happen. After some more testing, I found that there seems to be some problem in android which do not send correct information that app is put on background. I`ll try to investigate it a little more because it`s quite serious problem, I agree