Incredibly slow on Incredibly slow on Motorola G5S Plus

Martin Koster shared this problem 1 week ago
In Progress

Just downloaded and installed. It may take up to 10 seconds before a menu becomes responsive.

Comments (3)

photo
1

Good day Martin,

sorry for a delay in response, I (as the main app developer) was out of the office for a few days.

As I see, your device should be powerful enough to run Locus without any delays or slowness. Isn't there any other process running on background that may slow down the whole device, not just Locus? You should see this mainly in increased battery consumption in system settings > battery.

I would definitely recommend simply restart your phone, it usually helps on such a problem. Hope it helps to you too, let me know.

Menion

photo
1

No, there's nothing running in the background. Restart did not help either. Only a few apps really suffered from speed problems.

Found out it had to do with the SD card which was formatted as an internal card. I have improved performance quitte a bit by replacing my MicroSD card (speed 4) with a much faster card (speed 10). Locus map is not a speed monster, but it works much more fluently now. I will test for a while and if I enjoy it then will upgrade to Pro version.

photo
1

Good day Martin,

the speed of SD card should not has such huge impact on the performance of menu or other UI elements in the app, I'm really surprised!

let me know after some time you will use this faster card. If this will be the source of troubles, I'll have to purchase slower card for testing and we will also include this information into our knowledge base. Thank you.