Live geocaches no longer work.

Jan-Gerard van der Toorn shared this problem 1 month ago
In Progress

Since the last update, live geocaches no longer work. I can download nearest caches, but nothing is shown on the live map.

Xperia z3, Android 6.0.1

Comments (7)

photo
1

I forgot to mention : when I kill Locus and restart it, it works for some time. When opening Locus after a while (not closing it, just running in background), the GPS appears suddenly off and the live map problem occurs. Switching on the GPS does not solve the map issue, but both started occurring at the same time.

photo
1

Hello Jan,


Could you please write, which Locus map and Geocaching4Locus version you use?


You can also send me Geocaching4Locus app logs via Geocaching4Locus setting -> About -> Send feedback. It should open an email app with prepared message and attached ZIP file.

photo
1

I just emailed the log file(s) as is occurred again.

I am using Locus 3.31.1 and geocacing4locus 2.2.4.

photo
1

Hello Jan,


Sorry for later answer, I was off a few days.


Anyway I don't see any issue on Geocaching4Locus add-on side. From logs you send me is seen that periodic updates from Locus Map was successfully received by add-on, that's ok. Next I see 4 attempts to send Live map geocaches to Locus Map, first with 0 geocaches because Locus Map has been sent to background before finish, next three attempts sent 31 geocaches to Locus map without any crash or error.


@Menion Do you have any idea what could go wrong on the Locus map side?


App versions:

Locus map Pro 3.31.1

Geocaching4Locus 2.2.4 (latest one)

photo
1

Hmm as I think about it, only possible problem should probably be that G4L send data to incorrect version of Locus Map app.

Jan, do you have installed both (Locus Map Pro, Locus Map Free (Beta)) at once? If so, suggest to try to un-install Free/Beta version if it helps.

photo
1

I currently have Locus Map Pro, Locus Offline Maps, Locus Map Tweak, GSAK Database, and Geocaching4Locus installed.


I verified that GC4L is downloading data by monitoring the data usage per app, and when panning the map, the amount of data transferred by GC4L indeed increases.


After killing Locus and restarting it, the live maps work. Until some time later when the problem reoccurs.


So I think you are right that GC4L is downloading the data, but not sensing it correctly to Locus itself. Is there logging in Locus Pro such we can verify if the data is actually transferred between the different processes?

photo
1

Jan, you wrote also in your previous post that "When opening Locus after a while (not closing it, just running in background), the GPS appears suddenly off and the live map problem occurs.". When you open Locus like this, also initialization dialog appear? It looks like Locus is completely terminated by your system (when put to background), is it possible?

May you please try to enable settings > misc > Locus as a service option in Locus Map, if this makes a difference? Thanks.

I see only possible problem if app incorrect set inner parameter "is running" to correct value. Should not happen, but ...

photo