Locus Pro and Sony Smartwatch SW3

Tom Lindeboom shared this question 3 weeks ago
Answered

Since a couple of months my smartwatch SW3 continuously loses contact with Locus Pro. The bluetooth connection is okay, all other messages appear on my smartphone

I'm using the Sony SW5 vand an Huawei P10 Lite.

Also my Locus Pro is frequently terminated on my phone. Starting up Locus as a service helps a bit but doesn't solve it completely.

I don't understand this. It used to work perfectly.


Tom

Comments (4)

photo
1

Hello,

this is unfortunately a known behavior with some Huawei Android 8.0+ phones which may also affect other apps in your system. Huawei have already implemented and released a fix for some devices so I would first suggest that you check if your system is up to date.

Please also read through this issue http://help.locusmap.eu/topic/problem-with-locus-map-on-huawei-android-8-devices

If Locus Map keeps getting killed then the phone part of the add-on is very likely to also get killed or not receive expected data updates from Locus Map so add-on connection may be very unstable even if the bluetooth link by itself is fine.

So please check the system updates and check if you can get Locus Map to behave correctly first, this alone could solve your problems with the add-on.

Best Regards

Milan

photo
1

Hi Milan,

Thanks for your reply. I’ve noticed there have been a lot of system updates from Huawei in the last months. Just before I wrote this I’ve checked for updates and there is even a new update ready to install.

I’ve also noticed that I’ve lost some of the functionality of my Smartwatch since these updates.

As I’ve told you, running Locus Maps as a system service does help a bit. Tomorrow I’ll switch the system service off and will test Locus with this new system update. I’ll share the results with you.


Many thanks for this wonderful app. If I have to I'll buy an other cellphone. Tom

photo
1

The Huawei update was an additional update (DT.NLD 8.0.0.304(CT.F02))


The test went well. Locus stayed active but I strongly recommand to use the "system service"option on a Huawei P10 because it suppresses a lot of system attempts to minimize of even kill your application.


The connection with my Sony Smartwatch SW3 seems te be improved but I will test that extensively on thursday, when I'm following a KML track (today was just recording a track).


Regards,

photo
1

Hello Tom,

I am glad that the latest system update helped with your issue. Running Locus as a service is a must for Android 8.0+ devices at least for now.

I will resolve this topic as "answered" but if you have any trouble during your testing please feel free to write me again into this topic.

To be honest the add-on connection handling and reconnecting in case of failures could be handled better and mainly automatically because disconnects seem to just happen sometimes quite unpredictably. I will try to improve the connection in one of the following add-on updates (probably some time by the end of this year).

Best Regards

Milan

photo