Locus Pro says "no network"

JohnCNA shared this question 6 months ago
Answered

I upgraded my phone from Galaxy S6 to S8. When I turn on Live Map, Locus Pro shows "Downloading Live map caches: 0/250" in the notification area but it stays on 0. After a few minutes, Locus Pro gives error message "Network Unavailable". And will not download caches via the Live Map. Yet I have no network issues. I can access the web and if I open another geocaching app, it fetches caches from the live map with no problems. I've had the phone a couple days and have no other access or network issues with any of the other apps.


I uninstalled both Locus Pro and the Geocaching4Locus apps, rebooted the phone and downloaded them again. Still having the same problem. I was running Android 7.0 on the old phone and that's what is on the new phone. I logged out of Geocaching.com and back in again, too.


Any ideas why Locus Pro and ONLY Locus Pro would think it has no network connection?

Comments (5)

photo
1

Whew! I solved it. I had entered my caching name in the setup area but did not see an option to do so until I selected Pocket Queries in the GPS Tools area. When prompted to enable access to Geocaching.com, it started working. Very odd that the error message was not about not having Geocaching.com Live access. It said "No Network".

Anyway, all is well again!

photo
1

I'm afraid I spoke too soon. It worked for a while but after opening Locus a while later, it's not working again.


When I open Geocaching Tools, it shows "Profile not loaded". If I tap Load Pocket Queries, it shows the available PQ's and then when I exit that, it now shows my profile information at the top. Go back to the map and in the Geocaching4Locus popup, turn on Live Map. Status bar shows "Downloading Live map caches 0/250" and the counter never advances. After a few minutes, the error message "Network not available" pops up.


Earlier this morning, it was working fine. I don't believe I changed anything, but it has stopped working again. And as mentioned before, another geocaching app accesses the Live API with no troubles, so I know my account and the network is OK.

photo
1

Hello JohnCNA,


Sorry for your troubles. It seems some network / battery usage saver blocks Live Map feature in Geocaching4Locus add-on. Could you try to install bellow version over currently one to test if solve it?


https://www.dropbox.com/s/khkhv4n735bu33j/Geocaching4Locus-2.1.5.2-rc.apk?dl=1

photo
1

Ah, progress! And an acceptable work-around! Thanks for this!


No, your update did not fix the problem, although it seems to be a little better. The problem is actually intermittent. Most of the time it does not work, but every once in a while it does. This test version worked right away, but failed to work in subsequent attempts.


I had my phone set to "Medium" power saving. Based on your comment, I turned Power Saving off, and Live Map appears to work every time now. Obviously, I would like to see this fixed, but at least I can get it to work by turning off Power Saving altogether before using the Live Map option.


My GS8 allows customizing the Power Saving function. I turned off the option to limit network use with background tasks. Then I turned on Medium Power Saving again. Live Map seems to work reliably with the Network option excluded from the Power Saving function. I don't know why this would affect Live Map while G4L is active and I'm looking at the map, but Live Map has worked properly every time I have tried it, even after a phone reboot.


In a potentially related issue, every time I open Geocaching Tools, it shows "Profile not Loaded". If I select Bookmarks or Pocket Queries, it can access them. And when the BM or PQ panels are closed, it now shows my profile.


I have left Medium Power Saving turned on, but with the option to limit Network activity turned off. I will make a caching run later today, and post back if I have any more issues with the Live Map function.

photo
1

Yes, that is the work-around to this. I went out caching for a couple hours today and experienced no issues with Live Map.


Either turn off Power Saving altogether or edit OFF the option to limit network activity in the Power Saving settings.

Thanks for your help and pointing me in the right direction for this good work-around.

photo