Locus doesn`t enable (bluetooth) GPS when using "Disable when hidden"

kryshtof shared this problem 6 years ago
Solved

I use Bluetooth GPS with Locus and if I enable "Disable when hidden" option, it doesn`t re-enable connection when restored as it did in older version. So after I turn display off for a while or download geocaches using Geocaching4Locus I have to go to GPS screen and manually turn it on again.

Comments (7)

photo
0

I just found, that on GPS screen (Satellites) it does reconnect automaticaly after turning display (device) off/on.


And when I press Home key on the map screen, I see blue box "Device connection was lost" and if I turn device (screen) off, wait few minutes, turn it on again and open Locus, it does reconnect (blue box "Connected to Qstarz GPS").


So the problem is only on the map screen.

photo
0

Next discovery - when I disable "Settings/Sensors/Orientation/Auto change" I can turn display (device) off and after turning it on again it will connect to BT GPS automatically.


But if I open Geocaching4Locus it disconnects from GPS and I have to enable it manually...

photo
0

Hi Kryshtof,


I did some improvements to BT GPS connection system, so please check next version from market (after a few days).


behaviour that GPS is disconnected when you display screen from addon and GPS is not needed is correct anyway problem is that GPS is not reconnected back. In case of using BT GPS, I may suggest disable settings > GPS > disable when hidden, which will remove this "unwanted" disconnecting

photo
0

Not reconnecting to BT GPS is (almost) the same With latest version :(


- with "Settings/Sensors/Orientation/Auto change" disabled it reconnects after turning display off if I turn it on after short while, but if I let it turned off for longer time, it doesn`t reconnect (should I test exact time interval?)


- with "Orientation Auto Change" enabled it doesn`t reconnect at all.

photo
0

Kryshtof,


may you confirm that this feature still not work in last (2.2.0) version of Locus? Thanks

photo
0

With "Settings/Sensors/Orientation/Auto change" disabled it works great :-), but when I enable "Sensors/Orientation/Auto change" it doesn`t reconnect even after 5 seconds of screen off :-(

photo
0

seems I found problem. Thank you for pointing me on right path with "Auto-change" settings! Problem should be fixed now anyway I`ll appreciate confirmation