This object is in archive! 

Map auto-load doesn`t work correctly

svartbjorn shared this problem 6 years ago
Solved

I have two neighboring map areas covered by the same type of maps. If I start with selecting "Map auto-load" = No, then I only see the map selected. Fine. If I then select "Map auto-load" = "Auto-load maps of exactly same type only", it does NOT load the same type of off-line map when I move into the neighboring map area, rather seems to display a cached online map. So two errors: 1) it doesn`t select the same type to load even though it DOES exist; 2) it does load a map of other type even though "of same type ONLY" has been selected.


So "Auto-load maps of exactly same type only" and "Auto-load maps of same type (if exists), other type otherwise" behave the same way.


ANother error: If I after the above selections go back to "Map auto-load" = No, it still shows the neighboring map (but wrong type). It was supposed to not show any maps outside the selected map area. If I however select a map for a completely different area and then select the actual area again, then the neighboring map is not displayed any more.

Comments (28)

photo
0

I can add one more observation: When I have selected "Auto-load maps" on (either of the two options) and incorrect type of the neighboring map is shown, and if I now zoom in some levels in the beighboring area, THEN it switches to the same map type.

photo
0

same problem with auto load... i have turistic maps divided into 30 parts, in past version a didnt do anything auto load works when i selected one map other will shown automaticaly but after last update it dosnt...

photo
0

I have same problem too...

photo
0

guys, may you please check this version? https://dl.dropbox.com/u/8015949/2.5.... . I don`t have too much maps that should be useful for this task so I appreciate some feedback on this topic - speed, functionality. Thanks

photo
0

Hi all


version 2.5.1.2 - loading maps works ok, but loading maps it is slow compared to the old version / version 2.4....../


phone -samsung galaxy s2


test files- sqlitedb

photo
0

I get a FC in v2.5.1.2 if I load a track regardless the settings of map auto-load.


The regular Locus version 2.5.1 and the test version 2.5.1.1 are ok .

photo
0

Ahoj Menion, to načitávanie map pri verzii 2.5.1.2 map je dosť dosť pomalé ,ale už to funguje .


Ešte jedna poznámka k tvojej test verzi -rozdiel oproti starým verziam:


Použivam mapy rovnakeho typu sqlitedb , avšak v nastaveniach map musim mat nastavenu len poslednu položku - teda automaticke načitanie mapy rovnakeho typu /ak existuju/, inak iný typ. - pri tomto nastaveni to funguje


pri nastavení položky - "automaticke mapy iba rovnakeho typu" to načitavanie map mi pri verzii 2.5.1.2 nefunguje.


Pri starých verziach / 2.4...../ mi to načitávanie fungovalo aj pri tejto 2 položke , teda že mapy musia byť iba rovnakeho typu.


Ale toto nastavenie je nepoodstatné , treba skôr pozriet na tú rýchlosť načitávania , v minulých verziách to načitávalo mapy veľmi rýchlo.


ahoj

photo
0

1. to stejný typ/ libovolný typ neznamená jestli SQLite nebo jiný formát ale jaký zdoj je v mapě. Když se podíváš do seznamu map, u map stažených v Locusu je vidět i z jaké online mapy jsi jí stáhnul. Tím je myšlen ten stejný/jakýkoliv typ


2. co myslíš tou pomalostí? Zpomalí se ti při přechodu celý telefon? Nebo jen prostě trvá o vteřinku déle než se mapa načte a pak už je to ok?

photo
0

1.ok


2.ked sa prstom pohybujem po displeji tak 1 sekundu aj 2 trva kym sa novy usek mapy zobrazi.

photo
0

ad 1. fajn -- ono to spíše předtím nefungovalo korektně. Je to primárně proto aby jsi si mohl načítat jen mapy které mají stejný zdroj a ne aby se ti tam pletly nějaké naprosto jiné


ad 2. a během té 1 - 2sec se telefon nějak výrazně seká? Jde mi to jestli je problém že se jakoby zpomalí celé fungování locusu po tu dobu, nebo jen prostě delší dobu vidíš bílý kus mapy ale přitom se na rychlosti aplikace nic extra nezmění

photo
0

2. ano vidim biely kus mapy ,skor to vidim že to pomalsie načitava . rychlost telefonu sa mi nezdá pomalsia . V starých verziach pri presune to nacitávanie mapy bolo rýchle- v podstate som nevidem biele kusy mapy - tak rychlo sa to nacitavalo...

photo
0

aha... tu sa da aj tak ako mi zobak narastol a nemusim lamanou anglinou :)


vo verzii 2.5.1.2 mi uz automaticke nacitavanie funguje (ak zaskrknem poslednu moznost), len ako spomina smilan je to strasne pomale... 2-3sec nez sa nacita dalsi blok mapy.. v predchadzajucej verzii to bolo tak rychle, ze to ani vidiet nebolo... proste ako keby to bol jeden kus mapy :)


btw: mam zakupenu pro verziu, tak poprosim opravit chybu aj tam ;)

photo
0

... samozrejme že aj ja mam PRO verziu tak to bude hadam pre všetky .....

photo
0

:) tyhle test verze jsou jakoby PRO i když se nainstaluje jako FREE. Nicméně mají omezenou životnost, je to prostě jen na otestování. Až bude nová verze na marketu, bude samozřejmě pro obě verze. Každopádně dneska se na to podívám a kdyžtak sem dát zase něco na otestování ať vím že je to OK

photo
0

I tested the new test version. other than before the last update last week, it only loads the other maps when option "autoload if same type, other if not" is selected. Before it worked with my maps also when "autoload only when exactly same type" was selected. the later is desirable, because now it loads completely different maps, for example a hiking map when I view a street map. so not completely fixed I would say.


I can upload sample maps with about 300MB if needed if you tell me a ftp?

photo
0

so firstly: test version here https://dl.dropbox.com/u/8015949/2.5.... , should be much better now (speed problems)


secondly Oliver: what are map sources of your maps? Are you using maps created in Locus? If so, you may see in list of maps, green text with map source. If you have selected second option in "autoload" then Locus search for same map sources and use them (so for same green labels).

photo
0

Menion , teraz som skusil najnovsiu verziu 2.5.1.3 - je to už ok ... rychlost načitavania map je už uplne v poriadku

photo
0

dobrá práca...

photo
0

Hi Menion: I use Maps created with Mobac using my own VM-Server running Mapnik. I think it is teh rmap format (.sqlite).


In the past Locus would select the right tiles automaticly when I was moving through the maps even with option ̈exactly same map ̈(option 2). It worked very well. Now it is not anymore in 2.5 or 2.5.1 or the ones you offered here per dropbox.


Background: i have created different Mpas in differnt Zoom Levels (whole county, regional, city level) which I can copy to my device on a as need basis (delete for example if space is low). Worked really nicely and was one of my most favourite features :-)

photo
0

Hi menion,


did you read my reply above?


tramp20 22 hours ago


I get a FC in v2.5.1.2 if I load a track regardless the settings of map auto-load.


The regular Locus version 2.5.1 and the test version 2.5.1.1 are ok .


With the v2.5.1.3 I get the FC too: after selecting a track and just before Locus shows it I get the FC (the process menion.android.locus was unexpected closed)..

photo
0

tramp, I need some logcat, otherwise this not help a lot ... thanks

photo
0

Hi menion,


just sent it to locus@asamm.com.


Edit: I am now away with my MTB :-)

photo
0

enjoy a ride :)


and thanks for log. I was doing some experiments with Stefan here https://getsatisfaction.com/locus/top... and there remain one feature unsupported on your phone. So fixed now, next test version will be for sure correct

photo
0

Hi,


that fact that it worked, was only by luck or accident I think :) Locus have absolutely no idea which map source is contained in your map, when it`s created in different way than in Locus itself.


function "exactly same type" was, in case map have no defined source, just took first available map that can fill the hole. No, if map source is not defined (your case), it do not load any other maps. If you select last option, so "load whatever", it will just search for nearest valid map. Algorithm for searching has change a little so order of results is little bit different


best way to make it works correctly should be


1) place all maps, that you want to work as a one map, into one subdirectory (like Locus/maps/myMapPack). Locus will then take this pack as one map


2) tap on "tools icon" in list of personal maps (next to your map) and choose re-initilaize (http://docs.locusmap.eu/doku.php/manu.... This will say Locus from which source is this map and will allow to properly select them when needed by "auto-load"


Let me know if this is clear and works for you. I`m of course willing to improve it if needed, this should not be a final method

photo
0

Hi Menion,


that works for me, thanks for this tip!

photo
0

Track loading is now ok in 2.5.1.5.


Thank you.

photo
0

ahoj.kedy bude vypustena oficialna nova verzia?

photo
0

prosímtě rád bych na konci týdne, ale jelikož kromě této chyby tam nic zásadního není, může se to protáhnout až na začátek dalšího týdne