New addon - Field notes ignore time zones

layio shared this problem 3 years ago
Solved

Hello.


New addon for Field Notes ignore Locus option in Geocaching screen to ignore time zone. Now when I get found ex. 23:45 I get 1:45 (i'm in +2 zone), and this is incorrect when logging on opencaching.pl. Please fix this.

Comments (23)

photo
1

confirm

photo
1

I have a similar problem reported here:

forum.locusmap.eu/index.php?topic=4014.105


See Reply #114

photo
1

Hello,

I have the same problem - 2 hours difference. The composed log has correct time, but the "timestamp" of the note is +2 hours.


After uploding to GC the fieldnote date is +2h.


I didn't notice this issue in the previous version.

photo
1

Hello guys,


unfortunately I'm not perfectly sure, I understand where is a problem. In Locus 3.2.1 was indeed a problem with times in logs, so I hope it's related to this problem also. May you please try new 3.2.2 version of Locus if problem is still there? Thank you

photo
1

Hi menion,

1. i have logged a "found it" fieldnote online direct with locus, result 1 hour offset in GS-Fieldnotes

2. i have logged offline a "writenote" in locus, in second step i upload this with "Addon Fieldnotes" to GS, result 1 hour offset

34qr0g6

photo
1

Interesting, and what you see in FIeld notes add-on? And also what you see when you're in this cache and tap on Menu > Log your visit (to see list of log options and also already existing logs)


I'm testing it and it works as expected for me. So same times in add-on and also on web.

photo
1

Menion wrote:

Interesting, and what you see in FIeld notes add-on? And also what you see when you're in this cache and tap on Menu > Log your visit (to see list of log options and also already existing logs)


there it seams to be OK

334hoxw

photo
1

info: please use small '['img']' tags, not a big '['IMG']'. Thanks


Oki thanks, I'll try to find a reason for this ... interesting.

photo
1

Menion wrote:

info: please use small '['img']' tags, not a big '['IMG']'. Thanks


Thanks for info, i used it as provided from "tinypic" an wondere why other users are able to display images direct

photo
1

balloni55 wrote:

Menion wrote:

info: please use small '['img']' tags, not a big '['IMG']'. Thanks


Thanks for info, i used it as provided from "tinypic" an wondere why other users are able to display images direct
I was always fixing this after you with hope, you'll start writing small img tag on your own, but seems not :).

photo
1

Hello,


I can see again 2 hours difference, but the time zone is default 0:00. Is it possible to set the timezone as default? Where should I make this settings?


Maybe this will help


Thanks

photo
1

Hmm seems that if you disable 'settings > geocaching > use time zones', Locus takes timezone from lasttime, so in your case it should be by accident UTC+0. So you should enable this settings, store one log with correctly set timezone and then disable this settings. Sorry, I'll fix this also.

photo
1

I had "use time zones" already checked, so I stored one log with correct timezone and now the default timezone is correct (+2h).


So maybe there is no bug, I just didn't set the correct timezone?


Edit:

I checked that once more and:

In field notes timestamp and time in log are correct.

After sending to GC as field notes, the time stamp at GC web is -1h. Log text is corrrect

photo
1

I was working on this already yesterday evening and in the end, I spend on it almost 2 hours. Result was, that I completely overwrite working with time in first tab of "Log your visit" screen. So we will see in test version. I believe it will be fine now.


Only the -1h is little bit weird. Times are send on gc.com in UTC+0 zone, so it should be same time as Locus display in screen with cache details.

photo
1

Thank you,

we will see in next version.

photo
1

If you do not noticed, for already a one day is out BETA version, where all issues with time are hopefully fixed! So if you find time for a field test during next days, it will be really welcome.

photo
1

Could you please advice how to update the app to actual beta version? Thanks

photo
1

khkarel wrote:

Could you please advice how to update the app to actual beta version? Thanks
read top right on this page

https://plus.google.com/u/0/communities/105669867009952671671


@menion,

ill try it today ;-)

photo
1

Menion wrote:

If you do not noticed, for already a one day is out BETA version, where all issues with time are hopefully fixed! So if you find time for a field test during next days, it will be really welcome.
On GS Fieldnotes there is still 1 hour difference

Perhaps it depend (e.g. germany), on CEST= UTC+2h and GS only know CET=UTC+1h,

if so, we will see in two month

photo
1

I checked today v.3.2.3


On GC web the time is -1h compared to correct time.

Time in text of log is correct.

photo
1

Wierd, may you please check if you have correctly this settings on geocaching.com site?


LESexRC1SeKAozn3upmS

photo
1

Yes, I have the same settings.

Could it be the sommer time shift?


However I don't think the timestamp is big issue. In the beginning of this thread the time in Locus was already different. At least in my case.


Thanks

photo
1

Hmm I'm just testing it and if you uncheck "Adjust for Daylight Savings Time" settings in above screenshot, it has no effect! So it seems to be a problem on Groundspeak side ...