Points are moving in scale

Alex shared this problem 5 months ago
Not a Problem

I've use a Google map for preparation point. After it I export their to KML and import to Locus Maps.

Then if I scale a map the points are moving to map.

Comments (10)

photo
1

Good day Alex,

this looks like incorrectly defined so-called "hot-spot" point for your icon. May you try to use your KML file in Google Earth app? Or attach it here into the topic and I'll check where is a problem. Thanks.


Jiří M. aka Menion

photo
1

Ok!This is file kml

photo
photo
2

Good day Alex,

thanks for a file. How was created content of this file? Your own creation? Seems, as expected, that hotspot parameter is incorrectly defined for your symbol.

Should be this

<hotSpot x="0.5" xunits="fraction" y="0" yunits="fraction"/>
so try to change it, it should work. Btw. you may try it also in Google Earth where is result exactly same as in Locus Map.

Menion

photo
1

Hi Menion,

thank you for your answer.

Yes! I'm owner this file. I've created it in Google Map, not Google Earth. When I've imported this file to Google Map - point is stay to your place and don't moving.

After I've changed this attributes - point don't moving. But it is not comfortably for use. Because, if I've big file with many point I must to change many attributes. Do I have any way for change this attributes? I think easy way for change this attributes during import file to Locus.

Alex.

photo
1

Good day Alex,

some automatic change of this parameter over Locus during import is not possible.

Change by some global replace in for example Notepad++ editor is not possible for you?


Jiří M. aka Menion

photo
1

Thank you Menion.

I can change it to Notepad++. I think it will be good to fix to next version Locus because in other programs I didn't find this problem.

photo
1

Alex, there is nothing to fix!! In other apps is maybe not this problem, because there is not much application that is capable of handling hotspot parameters and other advanced features of KML files. After maybe seven years, it is for the first time I see this problem.

Also Google Earth confirms me, that Locus implementation is correct.

photo
1

Menion, I've created a point in Google Map - not Google Earth! And attach this file. And you have see that this problem is have place. I don't know, may be Google Earth export points with other tuning.

Write me if you know other way to fix KML-file without Notepad++. Because, now this way when I make point in first program, when I fix it in second program, next I use it in third program - is not good.

I don't write that Locus bad program! No! Locus good program! But now I've found a problem which interrupt me. And I want to decide it.

photo
1

Good day Alex,

please check official documentation for hotspot parameter here: https://developers.google.com/kml/documentation/kmlreference#elements-specific-to-iconstyle

In your case, you have defined this value: <hotSpot x="32" xunits="pixels" y="64" yunits="insetPixels"/>

Based on the documentation, it means that icon should be moved from it's bottom-left corner by 32 pixels horizontally and -64 pixels vertically. Because icon itself is 32x32 px, these values lay completely out of icon!! Why Google Maps display set these values is mystery for me, but they are definitely wrong!

I've tried three web KML viewers and all displayed icon without moving! but also without a color, so they definitely ignore some KML parameters. I always used Google Earth as only browser that display KML files correctly, so suggest to give it a try.

I'm sorry Alex, but I'm still really sure, that Locus Map system how display KML file is correct in this case!

photo
1

Hi Menion,

Thank you for your answer!

I'll try to create points in Google Earth.

photo