Recorded Tracks and Point are lost

Patrick Zadrobilek shared this question 5 months ago
Answered

I updated to Marshmallow, fixed SD-Card access for my rooted device via XPosed Module "Marshmallow SD Card fix" but when I want to access my Recorded Track it show that I have 0/15 tracks, but when I try to show them the list is empty and when I get back to the Data list, it shows 0/0 Tracks.

I have my complete Locus Folder backuped (from Nov. 2016) to nothing is lost yet, but how to I get back my Tracks and Points.


Any advice apprechiated.


Thanks,

Patrick.

Comments (7)

photo
1

Good day Patrick,

all points & tracks are stored in two separated databases. These are placed in Locus/data/database directory.


So if you have made manual backup ( btw. Locus Map should do automatic backups into "Locus/backup" directory, so you may restored them over "Backup manager" tool ) , you may also manually restored these two databases by simple copy to correct directory.


I cannot say, why, you data aren't visible anymore. Locus Map should anyway not delete any data, so it may be some copy & paste problem when moving to SD card? Don't know ...


Hope this helps, otherwise feel free to ask.

photo
1

I have found the old Data on the internal memory. Somehow the tracks were all on the internal memory and some other data (maps) where on the external SD-Card . I moved all data from the Locus Folder from the internal memory to the external SD-Card and now everything is back as it should be.


Cheers,

Patrick.

photo
1

Perfect, glad to hear it!

photo
1

Hi Menion

I seem to have a similar problem. I am missing my two latest tracks. I have 8 tracks recorded but for some reason, my last two are missing so it should be 10. I tried to open the tracks.db file in Locus but it says its unsupported. Is it possible that the "Number of track monitoring items" was set to 6 and so there was not enough space to record more?

Would really appreciate the help

photo
1

Good day Dominique,

there exists no limit to number of recorded tracks. From your description, I really cannot say why you miss last two tracks.

Did you used standard method to record a tracks over Locus: http://docs.locusmap.eu/doku.php?id=manual:basics:trackrecord ?

photo
1

Hi Menion

I feel like a real idiot because I solved the problem shortly after I posted this and I should have deleted it. My tracks were saved in a different file by mistake and so they were not ticked as viewable on the actual map but they were all there. I really hope you didnt lose sleep over this so I do apologise :-D


Dom

photo
1

No problem Dom, always better feel like an idiot then really loose a tracks ;).

Have a nice day,

Menion

photo