Screen On/Off Control - Turn on when notified during navigation not working

Darren Gibson shared this problem 20 months ago
Solved

I have an issue that my screen does not turn-on during navigation. Although this feature has worked for me historically (many months/versions ago), I cannot resolve it and wondered if this is an issue. I have the options:


  1. Screen On/Off Control - Enabled
  2. Guidance/Navigation:
  3. Turn on when notified of a point - unchecked
  4. Turn on when notified on a track - unchecked
  5. Turn on when notified during navigation - CHECKED
  6. Auto screen turn-off: 5 seconds
  7. Always screen on:
  8. During guidance/navigation - CHECKED


The navigation function is working and when I manually turn the screen on the correct navigation turn instruction is being displayed, I correctly get an "Out of track notification" when I stray off route.


I'm using version 3.23.1 on a Sony Xperia Z3 - Android 6.0.1.


Can you help?

Comments (10)

photo
1

Good day Darren,

I'm not aware of any issues with screen on/off system in Locus and also your settings should be logically correct.

May you please check in your device settings > Security > (Other security settings) > Device administrators if Locus Map is in this list and is checked? This settings is needed to make this feature working. Upon first usage, Locus should ask for this permission, but if it's denied, this feature may not work correctly. Thanks

photo
1

Hello Menion, thanks for you reply. The Locus Map app is shown and checked in the Device Administrators section so it's not that. I shall back-up my settings and uninstall/reinstall the App to see if that affects the behaviour at all, I think the App is great and rely on this feature - so I'm eager to resolve this issue.


Let me know if there's anything I can try, or provide to help diagnose the issue.


Darren

photo
1

I backed-up the settings and uninstalled/reinstalled the App and restored the settings. Unfortunately for me this did not resolve the issue, the good news is that the backup/restore function works a treat :-). Next step, is to restore factory defaults, and then set the screen on/off settings above and see how that goes.

I'll keep you posted.

photo
1

Hello, I can't imagine this should solve any issue. I'll prepare for you special test version if it's not problem for you, that will print us some information into file, to better identify where is a problem.

photo
1

Hi Menion, happy to provide diagnostic information to aid in diagnosis. Let me know when I can download the test version from and where I can find/send the log result.


Darren

photo
1

Hello Darren,

I wanted to prepare special version for you, but I read your description once more and I have few additional questions.


I'm checking conditions that should trigger this "screen on" event for your "Turn on when notified during navigation":

a) navigation notification like "turn on" etc. for distances shorter then 1000 m

b) "out of track notifications"

In both cases your should hear sound by your ears. Do you hear it?

photo
1

Hi Menion, sorry for the delay (work getting in the way). As stated in the original post I correctly get out of track notifications (i.e. [b] works as expected). But I don't understand you question regarding [a] ... is there another option that I should be setting to make a notification happen based on a Turn and where do I find these settings?


Note: The routes I use are imported KML/GPX files that I generate using gpsies and these routes do show me "turns" on the navigation screen.


So specifically to answer your questions:


[a] I do not hear any sound before a turn as a notification of a upcoming turn

> I don't know how to check/enable this setting if there is one.

> I do see a turn instruction on the screen before the upcoming turn when in navigation if I manually turn on the screen

> I have "Select Voice" set to "No Voice"

[b] yes I hear a sound.

> I have 3 beeps selected, and this is what I hear

> I have selected repeat every 20 seconds and this functions as expected


Darren.

photo
1

Good day,

thank you for additional information.


a) here may be a problem, because currently only in case any voice engine is set ( so any notification happen ), this screen on/off works. So I suggest to choose for example TTS voice and lower volume a test it.


b) this anyway should work correctly. In moment you hear your beeps, screen should really turn on. Maybe we talk here about guidance and not a navigation. May you please also in "Screen on/off" settings enable "Turn on when notified on a track"? Thanks

photo
1

Hi Menion, you've identified the cause of the issue. The screen works perfectly if I have a voice selected. I know that this didn't use to be the case as I do wear earphones. But it's excellent news that this has identified the cause and the screen now comes on before at turn. Thank you for your support here, very much appreciated.

Darren

photo
1

Good evening,

I'm glad to hear this.

I'll try to consider some improvements in setup of "Screen on/off" preferences, to make it more clear that enabled voice/sound system is necessary.

photo