Setting custom SRTM directory does not work on MM on Moto G (2015)

Michael Bechtold shared this problem 2 years ago
Closed

Good morning Menion,

other than UI for exprt directory e.g., for SRTM Locus does not offer the three dots on the right hand side of the list, where I can "select" the directory. SRTM way looks different than most others. "Backup" has the same weird appearance. You can navigate up&down, but not select. It is a completely different treeview.

Can you pls. help ?

TXs and cheers

Michael

Comments (14)

photo
1

FYI: the external SD under MM is shown under /mnt/media_rw/#######, also under /storage/#######

photo
1

Good morning Michael,


what you see are necessary changes made because of this: http://docs.locusmap.eu/doku.php?id=manual:faq:use_sdcard_on_kitkat#changes_in_android_50 ( section "Changes in Android 5.0+).


As you may see in mentioned page, three directories use special technique and may be placed on read-only SD card. For this is anyway need to use internal Android directory picker. Which looks as looks.


At least on my device is at bottom big button "Select directory". It has to be somewhere on screen, just search little bit :).

photo
1

Well, Menion, this article I read first before trying (and reporting the issue).

There is a button that I pushed while being IN the SD card SRTM directory (picking a directory from the folder list (with the three dots) is not available here).

But it had zero effect. No update of the directory in the Misc/DefDir for SRTM. No difference after restart.

Maybe Android 6 is YET again different from 5.x ?

photo
1

Hmm quite interesting. I'm testing it now on Nexus 7 with Android 6.


When I move in browser into directory I wants select and at bottom I press small button "Select", I'm immediately returned back to Locus, get a warning message (about need to move data manually) and in "SRTM" settings is set correct path.


Hard to say here. ROM you are using is official ROM from Motorola?

photo
1

Yes, official ROM, upgraded from 5.1.1 OTA. With 5.1.1 it worked properly - after OTA Update it broke. Weird.

photo
1

Michale I'm really worried I can't help here. I'm trying to find some useful information on internet related to problem with selecting of directories by internal file browser (which is this case), but seems, nothing.


What Locus do is really just ask to system to let user pick a directory. Then Locus waits on response from system that you (as an user) selected any directory. Unfortunately I need to use this method, as it's only method how to get write access to selected directory.

photo
1

Hello Menion,


I'm seeing similar behaviour here on a Galaxy S5 upgraded OTA to Android 6.0.1. The android directory picker appears, opens the folder on the SD card. Write access is granted, you can touch a folder. If you choose to apply, Locus tells you the process completed successfully. But the path sticks to default and nothing changes.


This was definitely not the case on Lollipop 5.1.1. Changing the backup, srtm and mapsvector directories worked without flaws.


Thank you for having a second look at this and sorry for adding to an old ticket instead of raising a new one.


Best regards,


Ralf

photo
1

This is clearly an issue that came with 6.x

We now have Moto G3 (where it worked with 5.1.1), Galaxy S5 and I can confirm the issue for the LG G5, too.


Good luck and cheers

Michael

photo
1

PS: there are Apps like Solid Explorer and others who can write to whole SD card, once you confirm the SD root directory. For Android 6, it may be best to request such right after installation, and then have an easier dealing with any write access later.

photo
1

Issue with selection of write-directory on Android 6+ will be fixed in next Locus version. I found this issue few days ago as well.

photo
1

Gr8 news - so you did find a way around the issue you mentioned 2 months back ?

photo
1

Hello. Which issue you talk about? Missing select button on your device? Nope. I finally have a device with latest version of Android and big display and even there exists a small "select" button at bottom of screen.

photo
1

Crazy - I tried with Beta again, created a new folder on external SD card, went INTO the new folder, tapped Select - and it worked.

photo
photo
1

Hello,


I did install the new Version 3.17.0 today on Android 6.0.1 and can confirm it's working again as expected for the backup, srtm, vector maps default directories. Same for the offline maps via the menu.


Thanks a lot.


Ralf