Switch off auto pause of track recording

wiel vercoulen shared this problem 4 months ago
In Progress

How can I switch off the annoying auto pause function ?

Everytime I take a short break during hiking I have to remember to start record again !

Comments (24)

photo
1

Hi Wiel,


this is interesting because Locus Map does not have any "Auto-pause" feature that would stop your track recording. What exactly do you mean by that? Could you please post some screenshot of the situation here? Thanks.

photo
1

Dear Michal, I was wondering about your reply. After every picknick I have to start recording again. Probably this issue is caused by the multitasking on my Phone during a break. When Locusmap is running in the background the recording is paused.

photo
1

I'm wondering if Locus recording isn't broken by you phone battery optimization mode. Do you use any? If yes, assign an exclusion to Locus from the mode or switch the optimization off

photo
1

Exclusion Phone battery optimization mode for Locus was assigned. Yesterday on my bike recording was paused everytime I was stopping searching the right direction. Very annoying behavior.

photo
1

It looks like this topic relates to the other one of yours - try the methods of excluding Locus from battery optimization on Xiaomi phones I recommended in the other topic.

photo
1

My Xiaomi Mi4c has Android 7 and MIUI 8. This has a different setting menu

photo
1

The parameters in the phone settings should be included - I myself have MIUI 8.3. Nevertheless, have you tried track recording settings > record only when moving - OFF?

photo
1

Recording only when moving is OFF. I switched off all battary saving options. Also switched off memory optimalisation an MIUI optimalisation. I will try again next trekking.

photo
1

Dear Michal, During our walking-holidays the annoying problem of the track recording still exist. Recording stops after a while. All your proposals don't seem to work. Please help !!!! The support of Locus is not optimal in this case. To illustrate the problem an example gpx file is attached

photo
1

Hi Wiel,

one last thing comes to my mind when I see your file - do you happen to have GPS auto-off option switched on? Check Settings > Gps&location > GPS auto-off. The recording indicates that sometimes your GPS goes off rather than Locus. Have you tried also some other track recording apps?

photo
1

Hi Michal, I can't find the setting for the GPS auto-on/off on my Xiaomi Mi4c with SW version MIUI 8 7.7.20 Your idea with the GPS function seems to be valid....

photo
1

It's not your system settings, it's Locus settings - go to Locus menu > Settings > Gps&location > GPS auto-off. If it is checked, uncheck. If it is unchecked, then I don't know how to help you. We can't simulate your problem - when we set a Xiaomi phone the way it is recommended in the article mentioned above, all works OK.

photo
1

GPS is auto-off is unchecked

photo
1

Last option is to analyse debug log from your phone. Run Locus, perform track recording, stop it when you are finished, stop Locus and tap *#*#284#*#* on your phone dial (works only on Xiaomi with MIUI 8+). You'll be prompted the debug log is being created. When it is ready you can find it in sdcard/miui/debug_log folder. Copy it and post here, we'll analyse it and hopefully find the reason of your issues.

photo
1

Debug log file is attached

photo
1

Hi Wiel, I'm afraid the attachment didn't come. Will you please re-send it? Thanks

photo
1

Can I sent it to you directly, function attach a file isn't working

bugreport-2017-08-21-171634.zip is 4,28MB

photo
1

ok send it please at michal.stupka@asamm.com

photo
1

Hi Wiel,

we analysed your bug report and found out that your system recognizes that (citation) "application hold GPS too long exceed the limit". Simply, your MIUI stops GPS when it decides it is used for too long time by some application. This state should be solved by measures described here http://docs.locusmap.eu/doku.php?id=manual:faq:gps_lost_fix_android6#xiaomi but for some reason, your OS still prevails.

We looked for more information and found this http://www.gizchina.com/2016/07/01/fix-strava-gps-miui-xiaomi/ or this http://en.miui.com/thread-311257-1-1.html but we don't think your state will be solved by it. The last option is to install https://play.google.com/store/apps/details?id=com.silentlexx.gpslock&hl=en. test it and if it won't help we can't help either.

photo
1

I've tried gps locker but the same problem persists.

photo
1

Hi Wiel,

have you tested track recording with some other app besides Locus? E.g. Endomondo or Runkeeper? Does it have the same problem as Locus?

photo
1

Hi Wiel,

on my last two bike rides I experienced something similar to you - Locus paused recording in the middle of the ride. In both cases the reason was that I forgot to lock Locus in the phone RAM - minimize Locus, tap left system button, drag Locus icon to the bottom, a lock icon appears, tap it, Locus icon moves back up and is marked with a blue lock (see screenshots). Of course I have made other settings before:

1. Xiaomi optimization > Battery > Battery saving > OFF

2. Xiaomi optimization > Battery > Applications > select Locus Map > turn OFF all limitations

3. Xiaomi optimization > Automatic start management > select Locus Map (allow to start automatically)

4. (optional) Xiaomi system settings > More settings > For developers > turn OFF RAM optimization

5. the step I described in the beginning

bdf957ff44bfc8bdf84b1b8eb04969b5

9d519a3929df60e960b1984e58750e02

photo
1

Dear Michal, Except the autostart option, all these settings where allready like your description.

I'm using MIUI9 (7.28.24 beta) now, and there's no different behavior.

I will try the Locusmap with the autostart

photo
1

Hi Wiel, then I would rather ask the MIUI community if there's a new method of preventing system from unwanted killing background processes. What I've written to you for these 3 months is all we in Locus team know...

photo