Track Recording Automatic Start x not working to stop it

Spartaner shared this problem 1 year ago
Solved

When automatic start of track recording is activated (I prefer it when using it during trips), a small pop-up-window pops up during start of Locus Pro, see screenshot. The pop-up-window shows a little x, which invites me to press it, when I exceptionally wish _not_ to record my track (for instance, when I play with Locus at home).

But nothing happens when pressing that x. I would wish to stop recording, when pressing that x.

Comments (9)

photo
1

Sorry, wrong file. Here is the right one:

photo
1

I am using Locus Pro on Xperia T with Android 4.3

photo
1

Good day Spartaner,

I'm testing this feature and unfortunately it works correctly for me. I mean that click on "x" button really dismiss this small dialog and track recording won't start after that.


What happen in your case when you tap this small "x" button? You wrote nothing, this means that even a small dialog does not hide?

photo
1

"What happen in your case when you tap this small "x" button? You wrote nothing, this means that even a small dialog does not hide?"

Yes, even the small dialog box does not hide. Please look the little video (35sec): https://youtu.be/bpBcXp-OkHc

photo
1

Thank You for a video.


In the end, I rewrote this small dialog and gave it little more modern design. So let me know in next version, hope it will work fine for you.

photo
1

Thank You, the new dialog works as expected!

photo
1

Glad to hear, have a nice day.

photo
1

But now I think it introduced a new problem for me, at least.


I have set the auto track recording after 5 seconds when opening locus.

Many times I want to cancel this as I do not need track recording.But now this dialog window is ""behind"" the window of initializing...personal maps loading etc.So, at times this initializing window it takes more than 5 seconds to disappear and now I have automatic track recording and I do not want.Please make red button window in focus when opening.


Also can we have a lower interval for autostart in settings, like 3 seconds?


Thanks

photo
1

Good day Marius,

good observation, thank you. I've changed order of actions that happen during start of app and "automatic start of track recording" is not moved to almost end of this list. So it should always appear after all map are firstly initialized. Thanks.


Current start delay is set to 7 seconds and agree it is too much. So I've reduced it to 5 seconds, good compromise I believe.