Track recording not saved

Viktor Finopoulos shared this problem 6 days ago
Solved

Hello. I am a user of LocusMaps pro. I used to record tracks waking and then press stop. I would then get the option to save the track in a folder. Now, when I press stop, the tracking tab simply closes and my measurements are lost. Furthermore, while time advances, the distance stays at 0. I've also attached a screenshot of a setting that might be causing the problem. For some reason, I cannot change this setting


Thank you in advance

Best Answer
photo

Hello. Accuracy 5 metres is even worst then before. This value say, that only location with accuracy better then defined value, will be saved. Suggest to keep at least previous 20 metres (I personally use 50m or 100m > these values say only "probability").

If you see colored area insted of plain line, then you probably enabled drawing of area in recording style: http://docs.locusmap.eu/doku.php?id=manual:user_guide:tracks:recording:profiles_settings#style_on_map . Check this option and disable at bottom "Close line and fill with color".

Comments (7)

photo
1

Good day Victor,

auto-save settings is greyed, because exact folder where recordings should be saved is not defined. This anyway won't be a problem probably.

You wrote that distance is still equal 0 and this will probably be a problem.

Do you see on the map blue circle (when you stay) or blue arrow (when you move) on your current location when GPS is enabled? If so, then GPS probably works correctly and the problem may be also 20 metres accuracy defined in your profile. Please also check just today published version that may solve some issues with GPS in the latest version that may affect this as well.

photo
1

Thank you for your reply. I did the update and changed the accuracy to 5 metres and something seems to be happening. (I've tried this before, but changing the accuracy didn't make any difference before the update). Now I got back to the point I was before, where an area instead of a track is recorded. Any suggestions about this?

photo
1

Hello. Accuracy 5 metres is even worst then before. This value say, that only location with accuracy better then defined value, will be saved. Suggest to keep at least previous 20 metres (I personally use 50m or 100m > these values say only "probability").

If you see colored area insted of plain line, then you probably enabled drawing of area in recording style: http://docs.locusmap.eu/doku.php?id=manual:user_guide:tracks:recording:profiles_settings#style_on_map . Check this option and disable at bottom "Close line and fill with color".

photo
1

Thank you for your reply. I set the accuracy back to 20 metres. The distance is being recorded, but the track still looks like a triangle. Here are some screenshots of my settings and my track. At least now I am able to save the track after pressing STOP!

photo
1

Oki perfect, first step done.

I see on your first screenshot, that saved! track has this "fill" style. During recording, you see correctly red line, right?

I think that you save recorded track into a folder in database. But this recorded track use by default style of a folder where is saved. So please check style of saved track. More about it: http://docs.locusmap.eu/doku.php?id=manual:user_guide:tracks:management#track_route_style

Maybe a little complicated, but I'm sure once you understand principle, you will like it :). Hope this helps, let me know.

photo
1

Yes, this was the problem. There was a universal setting for the folder styles. It is indeed a bit complicated, but once I understood how it works, it's in fact very practical. Solved, thank you very much!

photo
1

Perfect. I'm really glad that all seems to work correctly now. Have fun.

photo