Tracks doesn't show as it is in zoomed out map but it shows correctly in zoomed in map. how to fix?

Naoto Kogure shared this problem 2 months ago
Solved

Hi there,

Thanks for such great app. I enjoying to use it. But there is one problem. I have 48 tracks imported and it shows beautifully in 45, but 3 tracks show incorrectly. 3 of tracks show a quite different way than what it suppose to in zoomed out map but whenever I zoomed in these tracks show correctly. I have no idea why it happen like this. I have attached a picture that it suppose to look like, and I have attached a kml file that I imported. I would really appreciate if you help me out. Thanks in advance.

Comments (7)

photo
1

Good day Naoto,

Locus Map tries to simplify visible lines in case, they are too complex and you are zoomed out a lot. Which is this case. These three polygons have a lot of points in the complicated left border. Locus Map then tries, based on parameter map_items_track_simplification_till_zoom (defined in config.cfg) to optimize these tracks little bit.

You may try to change this parameter to value "0", if it helps (should).

photo
1

Menion,

Thanks for your input. I appreciate your time. But unfortunately, I couldn't locate the config.cfg file. I went to Locus/data/config then I tried to open config.db file but I couldn't. I knew pain in axx but would you mind uploading the custom config file that configured that section as 0? That would be great help.

Thanks in advance.

Nao

photo
1

Hello,

it is located in root of "Locus" directory in your internal memory (as written in our manual I linked to). I can upload it of course, but my is already highly modified so rather edit fresh original file on your own device.

photo
1

Menion,

Again, thanks but I looked into everywhere in Locus directory. Also, I installed 2 tablets and verified both, I couldn't find out. There is no such file. There is only one file in root, info file. Is config.cfg file available in free version? I was planning to buy pro version if this tracking show perfectly, so I was using free version now.

photo
1

Hello, really interesting.

So try to take a file from attachment and place it directly into root of 'Locus' directory in your device. Hope it will work.

photo
1

Menion,

Thanks for your config.cfg file. It worked perfectly. SOLVED!

Appreciate your time and advice.

photo
1

Perfect, glad to hear it. Have to say that this is not an unusual problem, so it is possible that this option will be later moved directly into UI settings in the application.

Have a nice day,

Menion