Tracks labels cannot be hidden?

Marius Moldovan shared this question 2 months ago
Answered

I have points and tracks imported into Locus, but if their number is big,then they clutter the screen and I cannot have a nice overview of the map. I tried to hide all POIs and in settings I had set for points and for tracks: Tap on point- Popup and Tap on track- Popup

I want the tracks to be displayed on map , but I do not want their labels to be displayed..they are big and opaque and they are hiding map information behind them. Is there a way to display only the track and not the label? When I want track info and name I can tap on the track and then display this info

Comments (7)

photo
1

Hi,

go to Locus settings > tracks&points > track label content > labels on map > select "do not show".

photo
1

You can also select 'On Hover'. Label is not displayed unless you place the cursor on it.

photo
1

Sorry.. I'm tired and cannot find this setting On Hover. Can you point me on the path to it? In settings/Points & Tracks?

photo
1

"on hover" is option only for points, not for tracks/routes. Track labels can be opened only by tapping a track, or labels can be displayed at starting points of tracks - simple or complex (or none, if you choose "do not show")


998b06a6b0dc780a0571ad1977cfabd2

photo
1

OK..thanks Michal for clarification

An automation would be great,though.

I mean ... if I zoom out past a predefined zoom level, the track labels and the point labels should disappear automatically in order to have a better overview of map and the tracks. And if i zoom back in, the labels should appear again to view information in close proximity

It would be something similar to what we already have now, with switching map providers when we zoom out past a certain zoom level.It can be put in the same settings category

Can you please make this thread into an Ideas?

photo
1

It's not necessary. This can be set in the "config.cfg" file that you can find in Locus root directory. Open the file in a text editor, find parameter "map_items_draw_labels_since_zoom" and change its value as you need. Then restart Locus.

photo
1

Yes, true ... Problem solved :)

photo