Unable to save recorded track in horizontal mode

Hannes shared this problem 2 months ago
In Progress

Hello, I own a Samsung A3 with a 4.7 inch display. There is a problem while finishing a recorded track. When I want to save the track it is not possible to finally save the track because the „save“ button is not visible and I can’t „scroll“ to it. I have to turn the phone to landscape mode that the save button will be visible in the display.

Would be nice to see this issue fixed because I want to use fixed horizontal mode.

Comments (7)

photo
1

Good day Hannes,

do you have latest Locus Map version 3.30.2? If so, may you please send us a screenshot? Because I'm unable to simulate your problem on own device. Thank you!

photo
1

Hello, to be more precise the save button is initially displayed in horizontal mode but when I want to edit the name of the track and the keyboard pops in the save button disappear and I am not able to hide the keyboard anymore no matter where I click and there is no way to scroll down.

I use the latest version but the problem persists since a few versions

photo
1

Interesting that you have such problem.

I've recorded expected behaviour in the latest version. You do same steps and compare to what is on video, you do not see bottom ok/cancel buttons above the keyboard, that's all right?

photo
1

Hello, yes I do the same procedure but the buttons in the video do not appear above the keyboard in my case (see picture). Also I am not able to scroll within the elements as it shows in the video.

photo
1

2fb3f170a0b3c189e76a3d67e4cf48f6

@Menion. Picture is by V3.30.3 RC : No buttons above the keyboard as shown in your video.

But I do use the "off screen" android buttons. (THL and Samsung)

photo
1

Hello 0709,

thanks, I just tried a test record. The keyboard disappears now with a click on the "back" <- button you mentioned and I am then again able to save the track because the buttons "appear" again. This is a working workaround.

But when I understand Menion right this is not expected (purposed) behaviour because the button do not stay in the screen when the keyboard opens. This is with your device the same case as I can see in your picture.

I also tried to remove the "text proposals" above the keyboard to leave more space (see my picture above the keyboard) but this does not change the behaviour with the buttons above the keyboard, too.

photo
1

Hi, I see now, that this problem happens in case of enabled fullscreen mode. I really hoped that with latest versions, problems with fullscreen were solved, but it looks that troubles continue.

Anyway simple back button press should hide keyboard and this bottom panel should be visible. At least on my device it works that way.

@0709 sorry Willy, but I really do not want to place any confirmation buttons in top panel. This old style exists on some screens (like POI Alert), but it's only because I not yet changed it.