Unit of time/distance circles is not shown

Guenni shared this problem 4 years ago
Solved

If I use the option "Shift map center", I cannot see the units of the time and distance circles, because they are below the visible screen. :(


I am using Locus Pro, latest version from Google Play (and I like it!!!)

Comments (9)

photo
1

"Time" is visible - because digits are above the mapcenter(curser)

With "distance", you are almost right. You see only one ring. right?

(see shot)

photo
1

Oki guys, but what you suggest?


Only what should simply solve this, is to place texts for distance circles to top, in case "Shift map center" is active.

photo
1

@Menion: Looks like a good idea. Do you have the possibilty to see if some text is off-screen? In this case, you may set it dynamically. But the most simple solution is to set it on top. (That would be okay for me; but this is not my post)

photo
3

Oki, I was playing with it, and firstly I was quite lazy, so first

solution was that during "Shift map center", labels were all at top.


But

after some work, final solution is as you suggested, maybe little bit

better. Now all texts will test if are visible and if not, they will

draw on second side of circle, no matter if is "Shift map center"

enabled or not.


Hope this will be usable working solution.

photo
1

Thank you, I will test it with next release.

photo
1

oki perfect. If anyone will have time, here is probably last testing version before release http://forum.locusmap.eu/index.php?topic=3698.msg26879#msg26879

photo
1

It works perfectly. Thank you!!

photo
1

Thx! It is perfect!

photo
1

Thanks guys, glad you like it. Problem Solved