Unreliable heading in cycling preset

jimmyfromthepieshop shared this question 1 week ago
In Progress

Hello fellow Locusts!

I have the problem that when I'm using the cycling preset when I am on my road bike the compass direction is wildly off due the steel in the handle bars where I have the phone attached affecting the phone's compass.

So the question is, can I change this setting somehow to use direction of travel according to GPS, and if not, would it possible to implement this function?

I thought this cycling preset was fantastic until I saw this problem and I'm sure others have this problem too...

Thanks and kind regards

Jimmy

Comments (8)

photo
1

Hello Jimmy

settings has changed...

enable "advanced mode" top right in preset window

next click on 3-dot button behind cycling > modify > Compass and try GPS or automatic

Wolfgang

photo
1

Hi Wolfgang,

Thanks for the help, I've now set this and will test it tomorrow!

I didn't realise I had to go into the separate settings menu to select whether to use the internal compass or GPS heading.

photo
photo
1

As I mentioned in another thread, I'd found that the automatic setting mentioned above (switch to GPS from magnetic above a threshold speed) wasn't working, and it ALWAYS used the magnetic compass at any speed. Magnetic compass was unreliable in the car. I'd switched to the always-GPS setting, and then it worked fine.

I'm waiting for the next beta to see if it's been fixed.

PS, Locusts, ha ha. :)

photo
1

Finally Google released the beta (3.23.2.3).

My problem is still there. I selected Auto-change, 1.0 km/h and went for a walk directly west with a strong magnet in my pocket. Walking briskly (4-6 km/h as reported on the compass screen), the arrow was pointing anywhere but west. I switched to Orientation via GPS, kept walking, and it pointed straight west as expected.

I'm not sure if this is the OP's problem, but it's my problem. (Actually I don't much care; I can leave it on Orient via GPS and live without the compass.)

photo
1

FWIW my 1km/h auto-change works perfectly in 3.23.2.3

photo
1

Hi, Menion has announced that he'd found the issue and fixed it in the latest Beta.

photo
1

That was fast, thanks.

Isn't he on vacation or something? Nothing is so serious (in my mind) that it can't wait a few weeks.

photo
1

Yes he is, just this week.

photo