Waypoints do not always stay hidden

skubko shared this problem 3 months ago
Closed

Hello,


in settings -> Geocaching, I have option "Automatic waypoint loading" set to "All types" as I want all types of waypoints to be displayed on the map when cache is imported to Locus. But then, I visit some waypoints and want to hide them, so I hide them one by one from POI -> Waypoints tab. It is working, points are hidden. I close Locus and when I reopen it again, those waypoints remain hidden. Until now, everything is working as expected. But, when I hide the last visible waypoint of that cache and the cache has no waypoint displayed on the map and I close Locus and reopen it, suddenly, all waypoints are displayed again on the map. I tested the same with multi select option (eye icon), it does the same thing. Once one waypoint is visible, only that waipoint is displayed. But when none of them are selected to be displayed, after new Locus start, all of them are displayed again. Could you please fix this that if I hide some waypoint, it actually stays hidden - also in case I hide all of them? Of course when I update the cache (G4L plugin for example), it is OK that all waypoint are displayed again, because cache got updated, in that case I perfectly understand that wayipoints are displayed (because of my setting). But when I hide all of them, I would expect that they stay hidden. I hope I explained it clearly :)...


Thanks in advance for your help.


Best regards

Martin

Comments (29)

photo
1

Hi Martin,

when you want to hide waypoints, use "hide temp map items" command. More in http://docs.locusmap.eu/doku.php?id=manual:user_guide:items:management#map_item_folders

photo
1

Hi Michal,

please read my post more carefully, that is not what I want to achieve... And by the way, I am importing points to Locus (not just displaying them automatically), so those are stored in Data and not in Map items section of Locus...

Martin

photo
1

Sorry, too complicated issue definition. If you have settings > geocaching > automatic waypoint loading ON then Locus auto loads waypoints of all caches that have these waypoints invisible, including those manually hidden in previous Locus session. That's how it works. If you want hidden waypoints to stay hidden after restart, deactivate automatic waypoint loading

photo
1

And again, not entirely true :)... Locus does NOT automatically loads waypoints hidden manually if there is still at least one visible waypoint in that geocache. Only when I hide manually ALL waypoints of that cache, then it loads all of them back. So one of those behaviors is not correct - it should OR always display all of them OR not to display them if they were manually hidden before...

photo
1

OK, I omitted the thing with one visible waypoint in my commentary. Nevertheless, that is how Locus is programmed - if there is NO waypoint visible and you have waypoint autoloading ON, it loads all waypoints. If you have atleast ONE waypoint visible, Locus considers such cache saturated by the auto loading mechanism so it doesn't autoload other waypoints.

photo
1

Well, and that is exactly what I am reporting. It should work in the consistent way - once that setting is ON, it should OR always display all of them, OR it should display all of them, but not those I hide manually. Of course I vote for option n. 2 :) The current functionality is not working consistently as it is no fully reflecting that setting OR it is not fully keeping my manually hiden waypoints stayed hidden.

photo
1

Good day skubko,

I'm thinking about this problem and to be true, I'm not sure about any better solution then current one.

Imagine you today let Locus auto-load all waypoints of imported 1000 caches for certain area. Then you hide them manually. What you expect to happen after a month later, when you start Locus again? "No waypoint loaded? You check settings ... auto-load enabled. What happen?" ...

In such situation, how you force Locus to load necessary waypoints you wants based on your auto-load definition?

Current system is simple: if you wants to display a cache: are all waypoints hidden? Apply auto-load.

photo
1

Hi Menion,


I understand what you are saying, but it is a question of technical options you have. And really, the current situation does not behave consistently - once waypoints are loaded, once they are not, so one can already now say what you are saying - why it did not auto load all of them when the setting is on :)... But as I said, the question is what technical options you have. I could imagine to extend the current option of auto-load with some + manual override, or whatever else. But the question is if you have somewhere a "mark"that could be used that this cache has been altered manually, so do not auto-load it for that one etc...


Martin

photo
1

You are correct, it is not consistent.

Ideal solution in this case should be: auto-load defined types of waypoints always. So no matter if one or few other waypoints is already "set to load", always perform auto-load action. Consider done.

Second step: your proposal. What you needs seems to be something like additional option in a certain cache "do not auto-load waypoints", right? Btw. what is usage of this?

photo
1

What I want is auto-load all of them for all caches, but when I decide to hide some of them, those should stay hidden (until e.g. the cache gets re-displayed on the map or updated). Just to remember it... If this is not possible, please do not fix the inconsistency :D... Imagine situation that I always import 1000 caches to Locus. All of them get their waypoints displayed. It is ok, then I keep working with Locus. But there are some caches that have for example 20 waypoints and you can imagine that if there is more like that, the map is full of wayponts and red lines. Therefore, for some caches I hide its waypoints. I do not want to hide the cache itself, because I want to know it is there, I just do not need to see its waypoints...

photo
2

I would like something done with this too. Consider my situation with waypoints:

GC57MPB - PraGeo - Tajemstvi Prahy. It has some 31 waypoints + 1 final location waypoint. I already visited them all, except the final location. Yet when I hide the 31 waypoints and leave only final location, then quit / start Locus, it shows ALL 32 waypoints. I just want to have Locus remember what is hidden, what waypoints I have already visited (by this I mean that I hide waypoints that I visited and do not want them displayed).

Edit1

And it's just one geocache, there are hundreds more waypoints in entire Prague. Thousands perhaps. It would be nice to hide them one by one as I visit them (as points of interest they are).

EDIT2:

Having automatic waypoint loading setting turned off is not an option, because then new geocaches I add dont have these waypoints automatically shown (which is important too).

photo
1

Marty, your situation is different and what you describe should already work!

Auto-loading system is activated only in case, no waypoint is visible for a cache. So in your case, if you keep enabled at least one (final in your case) waypoint, auto-loading should not happen! It does not work for you like this?

What we discuss with skubko is a problem, when you hide all waypoints and wants to not auto-load them after start app (because you already manually said that for this cache, you do not want any waypoints to be visible).

photo
1

I have just tested it, I hoped it would work as you described. But it didn't, I've hidden 4 waypoints for a cache (one parking, 3 points of interest - it's a traditional cache), exited Locus. Then waited a minute, started it again (it shows normal

"INITIALIZING ... PERSONAL MAPS

PREVIOUS STATE"


and they were there again, all 4 waypoints. I have tried to use the EYE symbol on top (which hides all waypoints) and when it didn't work, I have exited/started it again and clicked EYE symbol for each waypoint manually (to hide them). Then exited. When I started it, they were shown again.


Not sure why it does that and why it's not working. It's been doing this for a while and I just got used to it, but it's something I would like to work as intended. :- /

photo
1

Sometimes this happened for me as well. Even when I did not hide all of them (but kept some of them visible), after some time, they appeared all again :)...

photo
1

Interesting. Just tested and works as expected.

What is source of your caches? They are imported in Locus database ( menu > points ) or are you using some live map from Geocaching4Locus or any other add-on? In case of Live maps, I can imagine there should be a problem. But if caches are directly in internal Locus database, it will be more complicated and I'll need some steps to reproduce same issue (which is a problem, understand).

photo
1

For me, they appear every time Locus starts. And it starts is killed by my Android a lot. I have

1)keep Locus as system service

2)no battery restriction

3)have 3GB of memory, should be enough, I have almost nothing turned on


it still is killed a lot :-D my MIUI 9 just hates Locus.

photo
1

So Marty would be a better debugger here, because generally for me it works correctly, but from time to time they all appear back. I am using G4L plugin, but not live map, just to import all caches in my area to Locus as points. I keep them there and I add new cases, I delete found/archived caches etc. Therefore once I hide something, I want it to stay hidden. And as Marty wrote, I want new caches to be imported with all waypoints disabled... :-/

photo
1

I never use a live map, so that is one source of problem gone. My geocaches are a mix of "search X-km around a point, import bookmark, import PocketQuery).


I am willing to be a debugger here, sure - I am not a programmer, but I understand the basic requirements (a need to reproduce the bug, otherwise you can't do anything, as it works for you Menion).


Though:

"And as Marty wrote, I want new caches to be imported with all waypoints disabled... :-/"

I want the opposite - I want them all visible and then manually hide them.

photo
1

Sorry, yes, I meant it like that :)...

photo
1

Yep. Live map would be useful sometimes, but I am too much of a control freak, so I want geocaches to be solid. To stay where I put there, to move them around from folder to folder, hide/show their waypoints. Live map is too ephemeral for my tastes. But I get how many people use that feature, I totally get that.

photo
1

Hi Marty, just a few words upon the MIUI 9 "hating" Locus. Yes, that's right but there's a way how to tame it:http://docs.locusmap.eu/doku.php?id=manual:faq:gps_lost_fix_android6#xiaomi

photo
1

Ok, thanks if I ever need it (or others reading this.thread). The best would be to turn off optimalization only for Locus and keep it for.other apps. But it doesnt work. Not your fault Locus guys.

photo
1

I use Mi3 and RedMi Note 4, both with MIUI 9 and optimalization turned off only for Locus - without issues (however, all other measures must be used - automatic start management, locking Locus in RAM etc.).

photo
1

Closing incident without actual solution? Nice, thanks.... Last time I had this issue (after a long time) yesterday! - all previously hidden waypoints reappeared on the map, so it is definitely not solved....

photo
1

There was no reaction in this thread for two months, no one else has reported anything similar, Marty has written all is OK for him.

photo
1

Ok, so I can just hope that one day it will be somehow fixed, until then I can only get angry when that happens again that I need to find all of my previously hidden waypoints and hide them again...

photo
photo
1

However, for me it now works. I have hidden gei waypoints and they stay hidden. At least for now, we will see.

photo
1

I believe this is the first time this happened for me since we wrote about it here 2 months ago. I did not report it yesterday because I thought you guys are still discussing it together (as you were supposed to be a debugger guy, having the issue more often than I did :) )...

photo
photo
1

You know how it goes, when something doesnt work, people.are more probable o mention it han when things are OK.


It was and now is OK for me. Not sure when it happened, what did I do and what update foxed it.