WMS layers don't show up, can't be seen on the map

Arpad Orfi shared this problem 3 years ago
Solved

Dear Locus,


I have a problem with displaying WMS layers in Locus PRO.


NLC (Sk) – Lesné cesty doesn’t show up on my phone above the map of Slovakia. I’ve checked the map on their website (gis.nlcsk.org) and the paths can be seen there. Nothing appears on my phone, regardless of I enable this overlay via the WMS tab of the Map menu or via the Online tab under the Overlays group.


Also nothings appears if I select any WMS layer from OpenWeatherMap.org, e.g. temperature or snow. I’ve tried different zoom levels and different areas of the map.


Arpad

Best Answer
photo

If you do not know what CRS is, just leave it. Locus should really use best possible value.. Current problem is in styles for layers, not in CRS parameter.


And channel.... definitely this help desk system.

Comments (6)

photo
1

CRS

What is CRS? Is the value of it supposed to be selected by the user; or is it set by Locus to the correct value?

photo
2

Good day Arpad,


thanks for your report. It looks for me like an issue on lesnicesty.org web server, but I found a way that it may work in Locus. Hope it will solve also other WMS layers that not work.


Next time, please post also URL to web service and let me know, if in next version still be any trouble!


Thank you.

photo
1

OK, thanks.

I will report whether it works in the next version or not.


1)

Should I try to change the CRS number, i.e. select another value from the drop down list (in general, not just in this case)?

Or the most suitable number / the correct one is selected automatically?

(The user guide of Locus is pretty good, because it is quite detailed. But there is no info about this in the manual.)


2)

What is the preferred channel of asking questions about Locus in general – help.locusmap.eu or forum.locusmap.eu?

photo
2

If you do not know what CRS is, just leave it. Locus should really use best possible value.. Current problem is in styles for layers, not in CRS parameter.


And channel.... definitely this help desk system.

photo
1

Interesting: When I load “NLC (Sk) - Lesné cesty” from ‘Online Maps’, then it is displayed correctly on its own (without any other map/layer).

However, when I try to load it from ‘WMS’, then it can’t be displayed as a layer above a vector map, nor above a raster/online map.

photo
1

WMS service is a lot more complicated then a simple Online map defined by XML. Locus generate url for map tile based on many parameters and unfortunately in current version is generated STYLE parameter in a way, "NLC" server do not understand. In next version it should be fixed.

photo