Android 4.1.2, language problem

Josef Manfreda shared this problem 1 week ago
Solved

Problem with new Version using german language

I am not satisfied with the newest version 3.30.2, because I can not uns my home-language. My Samsung S3-mini has Adroid 4.1.2! My last Locus Version was 3.5.3. If you don't be able to solve this problem I like to use the old version.

Comments (11)

photo
1

Hi Josef,

and what is your problem / question?

I guess, you are looking for a download link of older Locus versions. If I am guessing right, links for downloading older versions of Locus you can find here.

c.s.g.

photo
1

@ Josef (Info for developper) Samsung phone German language: (D or A or CH) ?

http://forum.locusmap.eu/index.php?topic=6071.msg50819#msg50819

photo
1

Thank you,

What is the newest one, I can use with Android 4.1.2 in German (Austria)?

Best Regard's

Josef Manfreda

On 13.04.2018 22:40, Locus Map wrote:

photo
1

Good day Josef,

Language used in Locus Map on Android 4.x should be exactly same as language set in your device.

So, your device is set to "German"? If so, then Locus should be also set to "German" translation.

photo
1

Samsung AND language D (Austrian version) ? I suppose= identical problem.

http://forum.locusmap.eu/index.php?topic=6071.msg50819#msg50819 (no change by latest V 3.30.3)

photo
1

Wait wait. You try to tell me, that even if your system is set to "German (Austria)" localization, Locus Map still display in English only?

Ah, I'm just testing it on Android 4 and indeed, damn! If I set de_AT locale, translation from de_DE is never used. This does not happen on Android 5.0 where Android correctly use rather de_DE then default en locale. Complicated problem.

...

I believe I've found a solution. The same issue may happen for French and Spanish, so I've fixed it for all these three localizations. Thanks for a bug report. In next version, it will work as expected.

photo
1

Thank you!

when can I download the new version without this bug? But better, can you send me the dowloadlink then?

best regards

Josef Manfreda

On 16.04.2018 13:20, Locus Map wrote:

photo
1

Unfortunately, you will have to wait on next update on Google Play. Not sure if there will be another bug-fix version next week (depends on number and importance of issues in new version). In the worst case, you will have to wait up to the month to next version. An alternative solution should be to set temporary "Deutsch (German)"as device locale.

If this is a big problem, I may share some older version if you wants to risk it. I just have problems to find out in which version selection of languages worked on 4.x devices.

photo
1

Thank you very much!

It's not a great problem! I would be glad if you can send me a earlier version as I own it (my last version is 3.5.3 and it is rearely very old). Or give me a link to download it?

best regard's

Josef Manfreda

On 16.04.2018 13:40, Locus Map wrote:

photo
1

Hallo

Ich hatte auch dieses Problem

wenn man Deutsch (Deutschland) einstellt funktionierts

lg

helmut aus Österreich

photo
1

Vielen Dank!!!!

Nun ist alles O.K.!

Josef Manfreda

On 16.04.2018 14:10, Locus Map wrote: