Automatic backup does not happen

A. Weber shared this problem 3 months ago
Solved

Hi,

I've configured Locus Map to generate an automatic backup each day at 7:00. If I have a look at the backup settings, I can see that the next backup is scheduled for tomorrow 7:00.

If I look into the backup folder, I can see, that the last backup happened six days ago. I didn't get a notification of any backup failure.

Unfortunately the successful backup notifications are gone, that's why I didn't notice that the backups are not running for such a long time.

How can I get the automatic backups to work again?

Can we get the option to be notified about the outcome of the automatic backup back?

Thank you,

Andreas

Comments (9)

photo
1

Hi Andreas,

we removed "succesful backup" alerts on demand of many other users but kept the "failed backup" alert - have you seen any? How many backup files have you set to maintain? As for the backup time - it's just indicative, the accurate time is scheduled by the phone OS and may differ even a few hours from the set time. Do you use cloud backup? If yes, check if you are online. Make sure you have the latest Locus version - the online cloud backup is better secured against unwanted failures.

photo
1

Hi Michal,

I've installed Locus Map Pro 3.30.2. Attached are the screenshots of my settings.

Thank you,

Andreas

photo
1

Hi Andreas, could you please sent screenshot of your settings > miscellaneous > default directories > Set 'backup/' directory? thanks

photo
1

Hi,

See the attached screenshot.

The backup directory is located on my SD Card. Locus has permission to access it. Doing a manual backup works.

I've never seen any popup telling me, that the backup failed.

My guess is, that the scheduling fails.

Thank you!

photo
photo
1

Good day Andreas,

thanks @Michal for getting basic answers.

Andreas, your settings look perfectly correct, I see no problem there. Check please result of backup tomorrow and we will see.

Anyway as I see, you setup backup to external SD card. I do not know about any problems with backups on SD card (I use it as well), but! in case of any problem, Locus should be doing backups into internal memory instead. Into default Locus/backup directory. So suggest to check this directory, just for the case.

If directory will be empty, please try also open "edit screen" of this automatic backup and just confirm it by bottom "set"button, just to set backup system once more.

Last question, what is Android version of your device? On older Android 4.x, because system also use some older methods with which we do not have 100% sure results, unfortunately.

Menion

photo
1

Hi Menion,

Today's backup was scheduled for 19:00, but nothing happened.

I rescheduled to 20:00 and pressed set. Nothing happened again.

I changed the backup directory back to default, exited Locus Map, then rescheduled to 20:20. But no backup either.

I'm running LineageOS 14.1 (Android 7.1.2) on my Samsung S7 edge.

Thank you,

Andreas

photo
1

Hi,

I think I found the problem. Automatic backup does not happen while Locus Map is running. When I exit Locus before the backup, it happens.

This is inconvenient as I never exit any app. Why should I do that? My phone has 4GB RAM and therefore apps are not very often kicked out of RAM by Android itself.

Thank you,

Andreas

photo
2

Hello Andreas,

this is very good observation. I've improved it now, so in next version when Locus will be put into background, device screen will be turned off (to not to disturb with backup during some other work) and no service in Locus Map will be running, backup should be executed as well. Thanks

photo
1

It looks like this is fixed with the latest Locus Map build.

Thank you!