Change rendering option in config.cfg while zooming in Locus

Nicolai shared this question 20 months ago
Answered

Hello,


two questions:

1) Is there an possibillity to change the rendering option in the config, while zooming in Locus?

Because at my device Locus is relly laggy, if I am zooming.


2) Is the "accelerate map rendering" option no more available in the config?

Comments (21)

photo
1

Good day Nicolai,

1) "change rendering options" ... what you expect to change?


2) second option was removed because it's implemented directly in app, so settings is not needed anymore.


If app is really slow, it should be caused by many options. Usually suggest to check map overlays, suggest to disable or at least do not use blend mode. Check also number of points & tracks on the map and reduce it's numbers. Also check map shading, that may also cause massive slowdown on slower devices.

photo
1

Ok


where can I find the second option in the app?

photo
1

It is a miss-understanding. This settings was removed completely, because it is no longer needed. All possible optimizations are made in app automatically.

photo
1

Ok


I thinks it's my device which cause the lags.

Or the cause is, that I have over 4000 geocaches saved in Locus.

photo
1

There should be no problem with number of points in database. Problem is always visible data on the map.


Did you tried to clear map completely? Hide all points, track, map items, wms maps, map shading, map overlays? Does it make any difference?

photo
1

Yes I cleaned map comepletely

It is than much smoother, but not as smooth as it should be.

If I only make about 40 of my 4000 geocaches visible it is lagging about that much, as if I make all geocaches visible.

photo
1

Latest version of Locus Map 3.21.1?

What device do you have?

You may try check "scaling of map icons", 100% helps here.

Custom icons for geocaches slow down a lot in case, they are more complicated.

Visible geocache waypoints may slow down map.

photo
1

I have the newest version of Locus. My device is Galaxy S4 with Android 7.1.1


the scaling of map icons is already at 100% and I don't use custom icons.

Here is an example video from me:

https://drive.google.com/open?id=0B-gA8KScGL5bM0pkWUNPZDRqUHc

First I zoomed with all geocaches visible, than I zoomed with all geocaches unvisible, and than I zoomed with some geocaches visible.


The crazy thing is, that it is only so laggy, while zooming. Scrolling through the map is OK?!

photo
1

Hmm, thanks for a video, unfortunately without visible fingers, I see nothing on a screen. even if, this does not help me to improve it.

Are you using Beta versions of Locus Map Free? If no, please install it over Google Play or manually here.

After start, follow these instructions:


  1. set all to situation, where Locus lags even if should not (like in case of 30 caches)
  2. then long click on main top left menu button
  3. there will be a "dev menu" with single option to start method called"tracking". Start it.
  4. after 10 seconds, Locus became registering everything what happen in device for 30 sec! So after these 10 seconds (you will see notification), start zoom in, wait till map loads, zoom out, zoom in etc etc. It will be even more slow, but it's ok.
  5. when this ends, in root of your internal memory will be file "trace_xxxxx.trace", so send me this please (probably zip it).

Thank you

photo
1

is there an beta for the pro version or only for Locus free?

photo
1

Only for Locus Map Free. This allows to keep Locus Map Pro untouched and use Beta without bigger worries.

photo
1

OK


I just tried it, but everytime while tracking Locus is so extremely laggy, that it everytime crashes

photo
1

Wait wait it crashed that you see "Locus Map was stopped" or you just see something like "Locus Map is not responding" with options "Wait" or "Close"? If this second, then it's ok, just press wait and really wait a while till all will be working again.

photo
1

it says locus is not responsing and i can choose wait or close app

photo
1

I just made it as you said, but I can not find any file in the root directory of my internal storage

photo
1

This is really surprising. Did you checked all root directories in "/storage/" or "/sdcard/" path? I've tried this on two devices and on both I've found file "tracing_xxxx.trace" in root of internal memory (not root directory of your device).

photo
1

I just find the files, they were not in the root directory

They were in these directory: Root/sdcard/Android/data/menion.android.locus/files

photo
1

Here is an zip file with the tracing datas. In the first one, I only scrolled through the map (which cause no lags) and in the second one, I zoomed into the map (which is really laggy).

photo
1

Ah, glad you found it.


Thanks to problematic file with zooming, I see a problem. It really seems to be, that you have huge number of points on a map and for Locus Map takes a while till separate which are visible and which not.


Please really check your data manager> points tab and also menu > more > map items , if there aren't any hidden loaded points, thanks.

photo
1

Thank you very much Menion!

I just found the issue:

There were another 4000 geocaches visible, which I have saved in another folder. I just made them unsivible and now it's much much smoother

Thanks!

photo
1

Hello Nicolai,

4000 geocaches, maybe also with it's waypoints, may cause a troubles to rendering engine of Locus Map. Glad you found it and disabling of them works fine! And sorry for a complications that has no obvious reason.

photo