Compass don't work after Version 3.23.1

Tarta shared this problem 3 months ago
Solved

After updating to the quoted version, my device compass does not work in locus. Using other apps like gps test the hardware always work.

I read some calibrations to do ... but I do not understand well.

With previous versions of locus always worked.

Thanks Tarta

Comments (26)

photo
1

Same pb for me with the last update. The pb happens randomly. When I open the compass and wait 15 seconds, it begins to work properly...

I never had this before the last maj.

I have a moto g 4g,with Android 4.4.4.

Thanks for your reactivity !

photo
1

I've got 3.23.2, and four days ago (same version I assume), I noticed compass problems too.

After some experimenting, I realized the auto-change feature wasn't working (auto-change between magnetic compass and GPS to determine direction). It would always use the magnetic compass, regardless of the threshold speed I chose. I tried 1 km/h, 1.8 km/h, but even when driving at well beyond that speed, it was still using the magnetic compass - which is unreliable inside my car - even though I'd selected auto-change.

photo
1

Hi,


there was some issue with compass in 3.23.1 but 3.23.2. works well. At least I'm not able to simulate it. Try to change your compass settings and don't use HW compass in a car or when your phone is mounted on a bike handlebars - all metal parts distort compass behavior.

photo
1

I have already installed the new version, but the problem persists.

I use locus for my trail running and for my hiking and the function of the "visual cone" is crucial to choosing the right pathway.

I repeat that the compass of my device works perfectly and before 3.23.1 even on lucus was perfect.

Can I install an older version, considering I have locus pro.

thank you

photo
photo
1

Hi Tarta,


can you describe in detail in what way your compass doesn't work? Have you tried calibrating it as is shown here?: http://docs.locusmap.eu/doku.php?id=manual:faq:how_to_calibrate_compass

photo
1

Yes i try!

Simply the compass is firm. By accessing the locus compass screen this does not move.

Now i try to upload a video...

photo
1

And what settings do you have in Settings > Sensors > Compass?

photo
photo
1

On my phone (moto G with Android 4.4.4., Locus pro 3.23.2), the compass remains OFF most part of the time on Locus. (The compass works well on other apps)


See picture :

ade17b303df093b0dc90e2e9a43e39fc


I tried to calibrate the compass following your video. The problem is the same.

I also tried the 3 different options in settings/sensors/compass. there is no change.


Because of this pb, I can not use the "visual cone" or "rotate the map"...very usefull options I use since a long time on Locus!

Thanks!

photo
1

Here is the problem exactly this!

I can not make a video, but the concept is that the compass is always fixed as in the figure.

thank you

Tarta

photo
1

Tarta, so it does not matter what settings od compass you have (settings > sensors > compass > hardware/GPS/auto-change), it is always not responding? What version of Android do you have? 4.4.4. as Sylvain?

photo
1

Android 4.2.2

When the speed exceeds 3 km / h I see the cursor in the shape of an arrow but not the visual cone as I set up and at zero speed I only see the point.

As in the attached picture.

photo
photo
1

Good day guys,

sorry for a complications. This seems to be really interesting issue. I've just made a small fix that I hope, will help here. During today will be published new Beta version so if possible, test it and let me know if this helped.

photo
1

Ok i'm now in the tester program and I have just installed the free version.

Now wait a beta.

Thanks so so much

photo
1

Just instal 3.23.2.2 nothing: the compass is still death like before!

photo
1

@ Tarta

you have to wait on next version.....

V 3.23.2.2 is a few days old

Wolfgang

photo
1

Ok thanks!

photo
1

@Tarta

at the moment the new beta isn´t available on google play,

so menion provide the new .apk as download

http://forum.locusmap.eu/index.php?topic=5615.msg47652#msg47652

photo
1

Just install the new beta but the compass is still.

I read in the release note that depends from the absence of gyrosensor...

Thanks for the support Mention

Tarta

photo
1

Good day Tarta,

may you please try to install this Locus Map Beta version: http://nas.asamm.com:8080/share.cgi?ssid=04QpSGp. Just install it, check if your compass settings in settings > sensors is set to "Hardware compass" and then return back and open "compass screen", or just enable rotation of map.


After that close app and in your device in Locus/logs directory should be file with additional logs, so send me this (attach it here). Thank you!

photo
1

Hi Menion!

Here the log (I have found 2 logs).

Thanks a lot for your support and developing of this precious app.

photo
1

Good day Tarta,

thank you for a logs. It show me that your device has all necessary components for using new system of sensors. If you have really set "hardware compass" in settings, then it looks like Locus Map does not receive any sensor data from system. Write me please here also what device you have. I'll try to search for some information on internet, thank you.

photo
1

My smartphone is Jiayu G2F (stock rom android 4.2.2 aosp).

Thanks

photo
1

Thank you for additional information. This will be a problem. Unfortunately on all my devices this works fine, damn.


Anyway just a quick test that problem is really in next "ORIENTATION_VECTOR" system I've implemented. A while ago was published new Beta version on Google Play, so it should be available within a few hours for download. In this version is enabled old system for all 4.x Android devices, so please try it and let me know if this works fine for you. If so, we'll at least know that problem is really with this new system only. Thank you for a patience and sorry for complications.

photo
1

Ok!!! Now whit 3.25.2.3 compass work !

It's a shame that the new system is not compatible with 4.x systems ....

No problem Menion! important is finding solutions.

Thanks Tarta

photo
1

Well it is not a solution. It just confirmed that something in your device is wrong, because on all other 4.x devices, this system works.


I'll try to create some solution to next public versiin, thanks for testing and patience. I am marking this as solved because in worst case, I'll this old system enabled for all 4.x devices, just for sure.

photo
1

Hello, ZTE Blade 4.1.2 compass does not work only in the program locus.

photo