Continues random crashes

SpiderTourer shared this problem 43 days ago
In Progress

I have crashes since some weeks/2-3 month. Don't know when it started.

Last Saturday crashed every 10-20 minutes half of the day.

I checked it on two different phones (Xiaomi Mi8 and Oneplus6. Oneplus 6 with LOS 15.1 and Oxygen OS 8.1)

Happend during Navigation and even when just showing actual location (I gave up with Navigation and followed the Route by my own).

It seems to crash more often when navigating but not only. Had two crashes when zooming via two fingers but it crashed by doing nothing, too.

No clear way to reproduce. Second half of the day it crashed "just" two times.

Is there any log Feature I can enable to help?

For know Locus is only usable for planing even when I had crashes while route planing but then it's not that big deal.

Pretty sure it's not only the new version. Had crashes for 2-3 month while navigating but then just 1 or 2 the whole day.

Comments (10)

photo
1

Even in 3.33.2 I got crashes. I created two interactive error reports. What is a secure way to send you such reports?

photo
1

Sounds like the same issue as reported here: http://help.locusmap.eu/topic/locus-crash_1

When you are able to install LOS, then I expect you are also able to take out the logcat after a crash. Pls compare that to the logcat in that other thread.

And yes, I am also running the 'latest' of all ROMs and apps and all: still I have regular crashes in Locus Pro.

The OP does propose a work around in the last post of the other thread: you could step into testing that as well. Mind that screen smoothness drops considerably (on my OnePlus 3T). Myself, I do not have test results yet using that Locus Beta.

photo
1

Thanks for the input. Could be the same even there a differences. For me it crashes during navigation or following a route. (but this produces renderings, too) It's original One+ 8.1 Rom and I'm using Locus for 2 years now and the crashes starts 2-3(?) month ago.

Logcat shouldn't be a problem. The only thing is it's not reproducable and happens when I'm driving which makes it a little bit difficult.

I just disabled hw acceleration.

We'll report back.

photo
1

I'm pretty sure my crashes are different.

I disabled hardware acceleration as it is described in the other Fred and still got crashes while navigating.

I have two new error reports.


@Locus Team

Now I have four interactive error reports for crashes. Two with hardware acceleration enabled and two with disabled. You are interested?

Again short main points

- crashes during navigation and manual follow the route

- happens on two different phones

- happens on original snd on custom Rom

-It is NOT the webview crash

- happens for some weeks after I used Locus for two years without any Problem

-> newly introduced issue

photo
1

Hello,

sorry for a delay in responses.

If you have any crash reports, please send them on locus.map@asamm.com email or upload them somewhere to cloud and share, thanks.

photo
1

Thanks for the response.

I send it via email

photo
1

Did you find something in the crash reports I sent ?

photo
1

Hello,

hmm I do not see any received bug report under your accout here on help desk, so

a) I fixed this problem and forget to write you here. In this case, please try new app version (from yesterday) 3.34

b) otherwise, please create new bug report with this new version, once more > thanks!

photo
1

With bug report you mean my crash files?

Got two crashes yesterday with 3.34. So I think it's not fixed yet.

photo
1

Oki, so may you please create once more, error and send it on our email? In bug-report system where are quite randomly send some crashes, I see few problems all in "native Android core". This not-technically means a huge (for now unsolvable) problem for us.

I'll look on logs, but if it will really be this kind of problem and older version worked, I see only solution in downgrade to older app version.