Download logs does not work for "Basic info only" caches

skubko shared this problem 8 months ago
Solved

"Download logs" button does not work for cache that was downloaded to Locus via G4L when "Basic info only" was checked in the preferences (Downloading). The cache is downloaded, it contains only tabs "Basic info", "Waypoints" and "Attachment". Then I want to get logs for this cache (not the whole listing, images etc., just logs), so I hit "Download logs" button. It starts to download logs, I see the progress bar, it finishes, but no logs are downloaded to the cache. The tab "Logs" does not appear in the cache details. Please fix this behavior. Thanks

Comments (10)

photo
1

Good day skubko,

this is really interesting behavior. I expect you have in Geocaching4Locus preferences set

- downloading > Basic info only ... checked

- downloading > Download rest info on show ... never


right?


Then you download and import some caches into Locus, display detail of a single cache and tap on "Download logs". Result is that nothing happen after small loading dialog? For me this method work, so please what I have setup differently compare to you? Also, are you a premium member?

photo
1

Yes, exactly as you wrote. "Basic info only" is checked and yes, "Download rest..." is "never". I import caches, display detail of a single cache and tap on "Download logs". I see the progress bar "Downloading logs", it goes all the way to the 100% and "small loading dialog" closes, but no "Log" tab displays in cache details, no logs are downloaded... Yes, I am geocaching premium member and I have Locus Pro; device is Samsung Galaxy S4 mini (GT-I9195), Android version 4.4.2.

photo
1

Very interesting because for me it works perfectly. @Arcao any idea what we may test and mainly what may be different on my and skubko's side? Thanks

photo
1

@Menion - do not you have checked "Download logs update cache" in Downloading preferences? I could imagine that if you have this checked, it is updating the whole cache and therefore you get also tab with Logs... but I am sure you are aware of this settings and that you have it unchecked the same way as I do :)...

photo
1

Ah very good point. No I have checked this option, thanks! With this value unchecked, I have same problem like you.


I'm testing it more deeply and for me it looks like in this case, geocaching4Locus is not sending data into Locus. Arcao, check this output I see in ContentProvider when Locus Map receive new data from G4L


eca7c730d9868430d0c5e90e966dd54a

photo
photo
1

You are right. Bug found. :( I will try to publish fixed version tomorrow.

photo
1

Thanks Arcao, appreciate it. Btw. I believe that just because of this is not necessary to make a new version. Tiny issue that probably highly depend on mentioned settings.

photo
1

maybe to release a new version and include also some ideas? :)... (small hint -> I posted two ideas yesterday :D )

photo
1

I've pushed fixed add-on (v2.1.5.1) to Google Play a few minutes ago.

photo
1

installed, tested, working correctly now, thank you very much for the fast fix :)...

photo