External themes do not work or bug?

Condor shared this question 4 months ago
Answered

Locus 3.31.3, LoMaps, external themes Andromaps_hc, Andromaps_mtb, OpenMaps_V7, etc.


Today I have tried changing theme (external) and they do not work. I do not know since. I do not use it often.

Basic LoMaps Themes work.

Themes work differently on older maps (bad) and on new (I updated) I do not work at all.

Some special mix.

Hmmm ... ???

Best Answer
photo

Now I've downloaded new themes directly from the Locus store (Classic Map). I use LoMap maps.

Here is the result.


+ BUG popup cache if there is no map of the area.

Comments (7)

photo
1

Mix themes

photo
1

Hi,

it's not a bug - I guess that these themes are not designed for LoMaps maps. Basically some parameter in header of theme *.xml file is missing and it's cause this issue. I can only suggest to download custom themes from Locus Store or from forum http://forum.locusmap.eu/index.php?board=40.0

BR Petr

photo
1

Thank you for your response.

I have used these themes (sometimes) for about 3 years. They have worked so far. Today I found this thing.

Three years ago I do not remember where they were from. But at that time as a beginner I'm definitely pulling only from the store or Locus forum.

Map 2017 works. I've updated 2-3 maps and it's only showing up on new ones.

Let's see others ;-)

On the screenshot is the interface LoMaps 2017/2018

photo
1

These themes weren't available in Locus store but it doesn't matter. Are you sure that they worked with LoMaps (maybe you use different vector maps)? However I don't want to waste time with it :) The theme is probably obsolete and it's definitely caused by themes...

BR Petr

photo
1

Now I've downloaded new themes directly from the Locus store (Classic Map). I use LoMap maps.

Here is the result.


+ BUG popup cache if there is no map of the area.

photo
1

ahh... :) The classic theme wasn't updated since April 2012 and it contained the same problem as your custom themes. Please delete folder /Locus/mapcVector/_themes/Classic Map, after that download theme again from Locus Store and test it again (I updated it).

BR Petr

photo
1

Theme now is OK. Thanks.

photo