Foto Poi doesn't work anymore

Erwin Huber shared this problem 9 months ago
Solved

Hi, since last update, when I want to make a new foto-point (foto-poi button in the menü leiste), locus crashs and ends.


(LG G4, Android 5.1)


Best greetings...

Comments (40)

photo
1

Can confirm. Happens to me on Android 4.4 Locus 3.23.0

Either when taking a photo poi or trying to add a photo to an existing point.

Tested with CameraMX and OpenCamera

Camera app starts, takes a picture and the crashes probably on 'get it to

Locus' step. Locus creates point with no picture as a result.

photo
1

Good day guys,

sorry to hear it. Unfortunately I'm unable to simulate same problem on own device. Is anyone from You able to create for me a log by this method? Thank you very much!

photo
1

Just sent google drive share link to locus.map@asamm.com

photo
1

Me too :)

photo
1

Good day guys,

firstly thank you both for a log. For my big surprise, there is absolutely nothing useful in this log.


I discovered one possible issue in case, you have Locus Map stored in external storage (SD card) in app private directory, like /sdcard/Android/data/menion.android.locus(.pro)/files ... is this your case? If so, this should be fixed in next Locus Map version.

photo
1

Hi menion: yes, in my case its as you told above: .../sdcard/Android/data/menion.android.locus.pro/files...

So i found out, that locus crashes also, if i just try to open an existing photo on an existing point.

Hans

photo
1

I can confirm that I experience the same problem ("Take a photo" causes Locus Map V3.22.3 to crash and so does "Shoot a video").

"Record an audio" does not cause a crash. HOWEVER, if you attempt to play the attached audio recording, Locus Map crashes. (I sent the crash report via the usual reporting system.)

Similarly, "Select a photo" works correctly but if you attempt to view the attached photo, Locus Map crashes.

-----------------------

I just sent a debug log following these instructions:

http://docs.locusmap.eu/doku.php?id=manual:faq:how_to_create_debug_log

photo
2

Thank you Hans!


Taras, is will be same issue. Thanks for a log. As I see inside, you have also Locus Map in private directory on SD card ( /storage/BF0A-94E6/Android/data/menion.android.locus.pro/ ) . I had found that this is a problem in latest Google library ( https://code.google.com/p/android/issues/detail?id=226707 ). Fortunately I was able to made a hack to fix it, so in next version (at start of next week), it will work as expected.


Thank you and sorry for complications!

photo
1

.......and sorry for complications!


Don`t worry Menion, Locus (pro) is great....anyway!

photo
1

Having Android 6 and exact the same troubles with photo/video/audio like @Taras D described. Problem just occurs if Locus directory is external storage (SD card) in app private directory.

Problem does not occur if using internal storage (SD card) in app private directory or the internal storage public directory "/sdcard"

photo
1

Yep fine, this is it. Guys in Google probably forget that "some" phones still has second storage (SD card).


As I wrote, in next version at start of next week this will work again.

photo
1

Hi,


There is something more here, since I don't have at all (external) SD card on my device. When I take a photo points during recording, Locus 3.23.0 doesn't crash. It just works fine, and behaves as if it takes photos. Later on, when I inspect the recorded track I notice no photo was taken at all. When the track is exported as Kmz, the "doc" file show the photo points where recorded, but without referencing "jpg" files in "files" folder of the Kmz. Furthermore, when I check in "files" folder, it is empty. Also, the folder Locus-data-media-photo is empty. However, if I check in the Camera folder of my device, the photos are there. I attach herewith a track recorded yesterday, which demonstrates the issue.


One more thing, please notice in the attached kmz, the parameter "<width>1.325489254</width>" on the beginning of the file. So, the width of exported track is still something else than I set in settings (http://help.locusmap.eu/topic/width-of-recorded-track-and-size-of-route-points-in-guidance-mode). My settings are: 4px.


Svjetlana

photo
1

Hello Svjetlana,

really interesting. I'm checking it now and it works correctly for me. Maybe it is the same issue, hard to say. Wait please on next version at start of next week. If same issue happen again, log will be needed here.


About sizes. I believe it is now correct. Units you define in Locus settings are now based on device screen density. I call it "pixels" in app, but truth is that these are "DP" values. Thanks to this, when you move your settings and put it into different device, or if you export track and import it to different device, it should always look almost same to user. It just needs to round result values little bit ... hope this make sense.

photo
1

Hi Menion,


OK, understood. Thanks.


Svjetlana

photo
photo
1

hello everyone... i have a similar problem... Actually i have a similar problen to Svetlanas; my tablet behaves as if it takes photos. But when I checkfor the recorded point there is no photo saved. The point is created but there is no pic attached. A clue... after i have taken the pic when i try to save it, i get the message "unfortunately the app my gallery has stopped" . plz plz tell me that all my photos are saved somewhere in a different hidden direction which i will be able to locate (with your help...) and not lost!!!!


Eleni

photo
1

Hello to all,

I've just published new Beta version on Google Play (will be available for download within 1-2 hours), so please check it if possible. Thanks

photo
1

thank you... i guess my pics are lost. hopefully the problem is fixed

photo
1

Hello, sorry I've forget to answer to you.

Unfortunately I do not know what exactly happen on your device. So cannot say that problem happen before or after taking a picture. Suggest to check general DCIM directory on your device and also Locus/data/media directory where Locus Map stores took pictures. Hope this helps.

photo
1

nope, nothing there. i ll send a log report

photo
1

hi there!!!is the new app avaiable for downloading? if so, by which name?

photo
1

Good day Eleni,

I've just published only Beta version , full version will be on Google Play probably till end of week if no problem appear.

photo
photo
1

Hi Menion,


I have tested, with Locus 3.23.1, recording/taking photo POI/export as KMZ. I can confirm, still there is the same problem. I made testing on two different devices: LG G2 - D802, on android 4.4.2 (without external SD card) and LG Optimus L7 II, on android 4.1.2 (with external SD card). Exactly the same Locus settings on both devices.


When taking photo POI during track recording on the device with external SD card, Locus crashes. The same operation on the device without external SD card, records the track without actually taking photos as described in my previous post.


Furthermore the width of recorded track in exported KMZ is still: <width>1.3333334</width>. Seeing that in Google Earth is hardly possible, since it's too thin. As you said, it is nice if the recorded track width is expressed in DP values, for more comfortable usage (inside Locus) among different devices. However, when the user exports the track, in my opinion, it would make more sense that the Locus respects the user settings (Settings-Recording profile-Track width) and (Data-Recorded-Line style-width of the recorded track folder).


Svjetlana

photo
1

Hi

I installed the new version of Locus, but the problem persists.

I've never had a problem with previous versions.

I use "Moto g2" with android 6.0, with Locus installed on the SD card.

There is no longer in my andoid the option to transfer the APP to the internal memory. Is there a solution?

Use Locus Map Pro in an environmental organization in Brazil.

photo
1

Hi, again!

I solved the problem as follows:

1. full backup of the locus settings;

2. I uninstalled Locus;

3. Removed Sdcard;

4. I reinstalled Locus to internal memory, and recomposed the settings.


It looks like Locus no longer works with SD card on Android 6.0.


Excuse me for my poor English ...

photo
photo
1

Good day,

in latest Locus Map version still seems to be an bug when adding attachments in Android 4.x.

I've just uploaded new Beta version on Google Play, so @Svjetlana, maybe some others that have still this issue, please try it.


@João Carlos, you are using latest 3.21.1 version for Google Play? There is should work correctly on Android 6.0+ hmm.

photo
1

Hi Menion,

OK, I shall check it and report what happened.

Thanks for you quick response.


Svjetlana

photo
1

Hi Menion,

I juste upgraded to the latest version from the store (3.23.1)

Also having the problem here, on an Asus Transformer (android 4.4.2) with no Sd Card: each time I try to add a photo point the camera bugs on saving the picture and the point is created with no attachement. Cannot find the picture anywhere.

Tried different camera software with no results.

The camera works fine in standalone.

How can I help ?

photo
1

Hi,


I too just upgraded to the latest version from the store (3.23.1)


I confirm, still the same problems on my both devices.


Svjetlana

photo
1

Good day,

I was talking about Beta version, not a regular version. So if someone is brave enough, check latest Beta version is this issue is already solved there. Otherwise new version is planned on start of next week. Sorry for a complications.

photo
1

Hi Menion,


Sorry, I confused the versions.


I shall check it again.


Svjetlana

photo
1

Hi Menion,

I have checked the Locus test ver 3.23.1.8.

I confirm, now Photo POI works correctly on both of my devices: LG G2 - D802, on android 4.4.2 (without external SD card) and LG Optimus L7 II, on android 4.1.2 (with external SD card).

Thanks for your support.

Svjetlana

photo
1

Perfect, thank you very much for testing, this is what I've hoped to read!

photo
photo
1

Installed the beta version. Unfortunately same behavior: trying to make a photo out of locus (e.g. foto poi) leads to a force closed...


Just also installed new pro version - the same.

photo
1

Good day, this is really unfortunate.

You have Locus Map root directory defined on SD card in private Android/data/menion... directory?


Also, may I please ask for additional log from latest public version? Thank you very much!

photo
1

"You have Locus Map root directory defined on SD card in private Android/data/menion... directory?" Yes, I have.


Just sent you a email with the bug report...


Kind regards... Erwin

photo
1

Did you mean that with root? Then no, see Screenshot 1.All the others are standard.

But s. th. is also in a private .menion. See 2.nd Screenshot.

photo
1

Good day Erwin,

sorry for a delay in my answer ( small vacation ).

Unfortunately I'm still unable to simulate this problem on any of my devices, anyway I made some improvements that should cover also your use case. So if possible, test next Beta version ( planned on tomorrow ), thank you!

photo
1

With beta 3.23.2.3 there is no problem with photo poi anymore! Problem solved, well done :) Thanks!

photo
1

Ah finally!!! Locus Map full of hacks that bypass Google made crazy system. Glad to hear it that it works and thank you very much for a help with this problem.

photo
photo
1

Hi Menion,


Thanks for the (as usual) excellent support: problem solved here on my ASUS transformer with the latest version from the store (3.23.2 pro)

Best regards,


Thierry