Issues building library

Bill Johns shared this question 3 years ago
Answered

Hi,

I am having issues building the locus-api-android library in Eclipse. I have checked out the current copy from the google mercurial repository but get numerous errors when I try to build it

Is it building for you or am I doing something wrong? I have followed the build instructions on the wiki page for installation

Thanks

Comments (4)

photo
1

Good day Bill,

sorry for a late response.

Installation instructions on Wiki site http://code.google.com/p/android-locus-map/wiki/Installation , should be working. What error do you get?

Important is to check added libraries and projects in settings of every project.

If there will be a problem, I can generate at least Locus API as a JAR file for you. This should help.

photo
1

Menion wrote:

Good day Bill,

sorry for a late response.

Installation instructions on Wiki site http://code.google.com/p/android-locus-map/wiki/Installation , should be working. What error do you get?

Important is to check added libraries and projects in settings of every project.

If there will be a problem, I can generate at least Locus API as a JAR file for you. This should help.

Hi Menion,

Which jdk version are you using? I'm using jdk8 and I seem to be getting a lot of error relating to ExtrasStyle.java saying "Syntax error, annotations are only available if source level is 1.5 or greater".

An up to date JAR file would be great as I've been able to successfully use the one on your project page however it is quite old.

Thanks.

photo
1

All good now, I changed my compiler compliance level to 1.5 and was able to build the libraries. Works a treat.

Thanks for the great work

photo
1

Ah perfect, good to hear.