Mapsforge 0.5

Christian Pietzsch shared this question 3 years ago
Answered

Are you planning to update mapsforge to version 0.5 with Rendertheme V4?

https://github.com/mapsforge/mapsforge/blob/master/docs/Changelog.md

Comments (7)

photo
5

Good day Christian,


no there are no such plans. Locus implementation of MapsForge library has so much changes, that switch is not simply possible.


When there will be push from users or creators of themes about some incompatibility, I'll gladly improve implementation in Locus to support also new added theme options on my own.

photo
4

Hi Menion,

thanks for your answer. The topic got my attention because

the Locus can't support the next version of my favorite map theme:

http://www.openandromaps.org/oam-forums/topic/elevate-updates-und-testversionen-neuigkeiten#post-3857

(sry only German with English change log)

But I can understand that an update would mean a lot of changes for you.

photo
6

Thanks for understanding.


Tobias already contacted me and I'll try, during next weeks, improve support for some features from new 0.5 version. I'm won't be immediately, but soon or later ... :).

photo
3

Nice to hear

thanks in advance =)

photo
3

I now also ran into this, because I also use the vector maps and themes from andromaps. Now the themes have been updated:

http://www.openandromaps.org/en/new-elevate-versions-3-0-and-2-5

But indeed these new themes 3.0 are based on mapsforge 0.5. And quite kind of the guys at andromaps to also make updated themes 2.5 available that are compatible to Locus.

photo
2

Did I understand correctly that Locus v3.9.1 fully supports MapsForge maps v0.5? Or is this "only" something similar to MapsForge maps v0.5?