Outdoor point to point guidance (strict mode) not work

Konstantin Kostin shared this problem 4 months ago
Solved

Hello there. I am sorry , but i didn't found clear explanation about my question.

There is two menu Navigation and Guidance. I don't use Locus for Navigation by regular roads, so my wish to have point to point guidance. I don't need to alarm me that i left shortest way to the next point.

So i thought that if i put check box Guidance menu => Advanced settings => "Strict route following" is enough. But that's not the case, Locus trying to guide me to the nearest point of the Track. But i need to guide me from 1 point though whole track to the end, point to point, and if i detour a bit, it have to still guide me to the missed point, not to the next nearest point of a track.

How do i have to use Locus to get such feature?

Many thank in advance.

Comments (27)

photo
1

Good day Konstantin,

I'm surprised that it does not work for you as expected, because "String route following" should be exactly settings you may need. Please check also guidance > set next trackpoint option. This value is distance at which Locus map switch to next trackpoint so if is too higher, it may cause troubles you have.

If anyway issue still remains, please export your track to GPX and send me it. I'll look at it.

photo
1

Hello many thanks for your assistance and trying to help!

Originaly track was created in Base Camp, then it imported directly in Locus, and when in was imported there is only one issue - track point was double. But when you open it in Locus it shows correct sequence of the points.

Keep in mind please that start position is the same as finish point 1. That's would be the reason that Locus shows double name for the part of the track w96fe58e750b0477a63af8720c2fba9caf04c5ff6f8a91325b92a1dac24b409d6hich is repeated by the back way , but for the rest of the point—č both on map and in track details it's the same.

Extreme way it original track from Base Camp, Track from Locus it's exporter after from Locus.9d66a74c8f7ea1ec34f9989a8ab74a0c9ea0894284182550abb4871bd753df181032feda1284a95a096cbd7a290ff4d6fac33fff840f755cf6f44e06336abe21

photo
1

I am sorry, i cannot attach GPX files, i can or put them on One Drive either send you by mail.

photo
1

Hello Konstantin, thanks for screenshot. Please pack your file to *.zip file, then it will be possible to attach it to this help desk. Thank you.

photo
1

Hello.

Here is my tracks. Sorry for my stupidness, i didn't guess about archive.

Looking forward to hear from you.

photo
1

Hello Konstantin,

thank you for a tracks!

  • a) duplicate points ... they are really in GPX file itself, so it is not an issue in Locus Map. In GPX file is list of separate points and also one track created from rtept points. This is not a correct behavior.
  • b) problem with strict guidance is interesting. I've indeed found an issue in Locus Map (for my own surprise). Consider it solved.

If you notice any new more problems with guidance in next Locus Map version (estimated release is on next week), let me know here. Thank you and have a nice weekend.

photo
1

Hello.

Many thanks!! about track it's a bit strange, in Base Camp it looks ok, no double points, when you export it in GPX and then import into Locus, double point appear. But i will learn it deeply on various tracks and will let you know if something is wrong.

Looking forward for next release!

Konstantin!

photo
1

Hello,

not sure if Locus Map behavior is correct or not to be true.

Anyway I have just tried to load your file into

  • Google Earth : no visible points, tracks
  • GPS Track Editor : error: no track
  • My Tourbook: parse error, invalid file
  • QLandkarte: finally someone loaded it correctly

Anyway agree that probably better behavior should be if Locus merge rtept points of track into track itself. It is anyway not how was Locus Map made, sorry. In this case, I may also suggest not to merge waypoints to track during import and just import points into some "trash" folder where you may later delete them.

Thanks for understanding.

photo
1

Ok.

Probably something wrong with my Base Camp.

But that's not a big issue - could be solved on my side for sure.

Many thanks again!

Konstantin.

photo
1

Hello.

Might be i am wrong, but there still no updates?

Konstantin.

photo
1

Hello,

small delay, sorry. Version is in preparation and will be updated probably tomorrow 7. 3. 2017. Thanks for understanding.

photo
1

Though i missed something.

No problem will wait.

Many thanks!

photo
1

Hello Menion.

It looks like it works the same. I got already 2 updates but it doesn't work properly.

Please check it.

Many thanks in advance.

photo
1

Good day,

I'm testing it and have to say it partially works compare to non-strict mode, but agree it's not perfect.

I spend on this some more time and I think we have now moved to another step, so wait please on next version, I'm almost sure, "strict mode" will work perfectly in next version. Thank you for your patience.

photo
1

Hello Menion.

There is still nothing? Yesterday i was trying to create my own short track to check "Strict mode" but it doesn't work at all, at the evening i can send you screenshots.

Konstantin.

photo
1

Hello,

"still nothing" means that it still does not work with latest 3.22.2 version? Hmm it should.

Ok, some screenshot and track for additional tests is welcome, thanks.

photo
1

Hello.

I think i did catch the few problem

  1. If GPS is on is still goes to nearest point of the track to your current position - so "still nothing" is about it - it was absolutely the same before
  2. If GSP is off everything much better BUT

  • If you are closer to point 1 it leads you to point 1, if to point 2, then to point 2 ? not 3-4-5-6-7 etc. it plays between first two points
  • Tap on menu "next point" many times (depend from what point do you start 1 or 2 see previous in my list of issues) it lead you to 3, 4, 5 ...5 ....5, 6 ....6....6 and so on, could be many times between some point you have to tap 2-3 times to get next number of point, and i guess why see below
  • Then, because GPS is of (second way is to tap on menu "next point" many times) you can imitate like go on track the system create additional point between real points - they are not in the list, not marked nothing but after 5 for example you get 2 additional invisible point before 6 ....
  • If you imitate going on the track when GPS is off - you just move position through tack\point - it's easily let you miss any point and even few point

So i think there is 3 bugs - strict mode still doesn't work when GPS is on at all, and track consist many many more point which i do not see, cannot find them correct etc. When you moving on the track you can easily miss the points so system just goes the nearest next.

photo
1

Here some screens, and track, if you need more please let me know.

Many thanks in advance.

photo
1

Good evening Konstantin,

thank you for a tests and precise description. Seems that issue in your case are mainly automatically generated points along track that change expected behavior.

May you please try one more test? Try to enable also Settings > Guidance > Advanced > Notify on every trackpoint. This settings prevent Locus Map from generating of these extra points. It should help here I believe. Thank you!

photo
1

Hello.

Yes it works, no extra points. Works step by step through whole track, BUT if you tap on the track, tgen you choose track menu, then you choose Nsvigate\guidance =-guidance it starts not from first point, but from nearest to current position or any point when GPS is off or ON doesnt matter. So its still doesn't work.

photo
1

Hello,

fine, then I think it works correctly. If you are somewhere in the middle of track, why you should wants to navigate since first point? Btw. did you tried to tap on first trackpoint and here choose "Guidance"? Anyway in this case, you always may start navigation/guidance to start trackpoint and later start guidance directly along a track.

Also when you start your journey at start of track, then all from your description, works as expected.

photo
1

Hello.

Everything was tested, works just Perfect!! Many thanks for your assisance and help.

I have two small question offtop, if so i can open new topic, if it's acceptable please answer here

1. Wold it be possible to increase thickness of the giudance line which are connect actual place with the next point, very uncomfortable - the line so thin - so when you are moving you cannot see it at all)) is there any possibility to do it myself?

2. Guidance panel - is there any possibility to increase it's size as well as the previous point in my question?

Many thanks in advance!

photo
1

Good day Konstantin,

I'm really glad we have finally working solution, perfect.

1. I'm not 100% sure which line you think (screenshot may helps here), anyway most of lines are affected by menu > settings > maps - points & tracks > track width, so suggest to try it.

2. currently there are no possible modifications of this panel. You may give a try to "dashboard" system.

photo
1

Hello.

1. About dashboard clear, ok will try to use it, adjust etc.

2. In attached file you can find what line i was meaning - the rest of the lines could be adjusted easily - color, width etc. But this line as i understood not.

Many thanks in advance!

Files: 1.jpg
photo
1

Hello,

ah this line. Seems you had copied config file from older device? If you modified "config.cfg" file before, you need to modify "guiding_path_symbol" variable like describe here , otherwise simply delete config.cfg file in root of Locus Map directory. This should help.

photo
1

Everything works fine.

The last issue - when you switch on Dashboard , you can choose many parameters to show, in my case i need only two - distance to next point of the track and name of the next point. Name works fine either you choose guide to only one point in a track or you choose guide through whole track - you can see it in attached pictures. But with the distance it doesn't work as that - with separate point all ok, but with the track it shows "-". Would it be possible to fix it?

Many thanks in advance!

photo
1

Perfect, glad to hear it.

Discussion about your problem continue here: http://help.locusmap.eu/topic/issue-with-distance-to-a-next-point-in-the-dashboard