Preventing the lockscreen doesn't work since update

Torben V shared this problem 1 year ago
Solved

I normally use the option that prevents showing the lockscreen of my phone after the display is turned on. After the last update I recognized today that the lockscreen is now shown. Option is still on.


I have a Samsung G. S3 with android 4.4.4

Best Answer
photo

In next version will be an option to choose "disable lock screen" as on screenshots. So all will be happy again I hope ;).


0c18e5d9cdefee8c1b965475ff6ac4d9

Comments (35)

photo
1

Good day Torben,

In latest version, Locus is able to disable only non-secured locks screens. So if you use some code, pattern to unlock, it won't work.


Reason was that previously Locus used small hack, that unfortunately don'twork on all devices correctly, so I've rather disabled it and now it's used only standard recommended method.

Thanks for understanding.

photo
1

Hello Menion,


That's a bummer. :-(

I guess this change has something to do with the other topic I've posted concerning this (http://help.locusmap.eu/topic/locus-pro-freezes-after-screen-offon)?


In the meanwhile I'm used to the workaround I've already posted in the other ticket, but as I understand now, once I've upgraded to the latest Locus, I will have to enter my pincode each time I've had my phone's display switched off?


While hiking, I regularly enable/disable the display to quickly check if I'm going in the correct direction. Being obliged to enter my pincode each time will be a real annoyance.


I know that I can disable the lock screen, but I prefer not to do so. I like the idea that everything except Locus is not accessible. I also don't want the display switched on all the time to save battery.


Is there another approach to get what I want (lock screen + switch display on/off and enter directly into Locus)? Maybe to an alternative (non-stock) lockscreen?

Or do you think that in the future this feature can be reimplemented?


Thank you,


Jeroen

photo
2

I agree with Jeroen and would also like to have this feature back. I use it for the same reason as he mentioned, but also for biking... Now I would have to enter the pin (while driving) only for checking a second, if I am still on my track... thats annoying as he already said and of course more dangerous while driving. So I now have to enable/disable the lockscreen each time I use locus :-(

photo
photo
2

In next version will be an option to choose "disable lock screen" as on screenshots. So all will be happy again I hope ;).


0c18e5d9cdefee8c1b965475ff6ac4d9

photo
1

Oh thanks !!!


Due to my job obligations (unatended phone could be abused by a person to connect to company data) I MUST NOT switch off the phone lock. That's why it is essential for me that Locus itself can trick it when on.

photo
1

And one more little wish (but much less important than the main topic of this thread):


When you change this part of code anyway, IS THERE ANY SIMPLE WAY TO EXTEND THIS "LOCK DISABLE" TO DERIVED DIALOGS TOO ?

I have already mentioned somewhere - on my Android 5.1 even if the Locus screen lock works, it does not work for istance when a new wpt coordinates are to be input. It looks like Locus freezes but it does not - only the lock prevents it from showing the dialog. When I switch to desktop, unlock the phone and switch back, the dialog is there.

photo
1

What you want is not possible. Mainly because of this, I disable this feature in 3.16.0, so sorry.

photo
1

OK, I understand, I can live with that, important that the lock can be disabled again for most Locus features in next version.


BTW, does any Android 5.1 device behave like described or this is specific for some devices like my Lenovo Vibe Shot ? If all devices behave this way, you could display some warning in these situations or refuse the operation (like "Please, unlock your phone first."). But it is just an idea and there are more important things to implement in Locus.

photo
1

To be true, I'm not perfectly sure and also documentation for developers is not perfect here. From what I've read and tried on own devices, it depend mainly on lock screen you use. If device manufacturer changed lock screen to some own solution or you use any custom lock screen, it may behave completely different. That's why only settings "Unsecured lock screen only" is recommended as it should work on all device in same way. "All lock screens" is really just on own risk. Thanks for understanding.

photo
1

Is trusted agent API shall solve the issue? http://nelenkov.blogspot.fr/2014/12/dissecting-lollipops-smart-lock.html


It seems to be design to do what we expect.


Regards

photo
1

Hello Thomas, thanks for information. Indeed it may be on first look a method, that may solve this. On second side, I can't believe that such simple task require such complex solution. Also as wrote at bottom "While they can greatly improve device usability, none of the currently

available Smart Lock methods are particularly precise or secure, so they

should be used with care." To be true, I don't have much feel to deal with it now. Thanks anyway.

photo
photo
1

Hi Menion,


Thank you very much. Highly appreciated! I look forward to the next release. :-D

photo
1

Thanks a lot for your fast work! You are doing a great job! *thumbs up*

photo
photo
1

Hi Menion,


many thanks from me too! Could you say, when the next Locus Map version with the new disable lock screen option will be released?


tkansgar

photo
1

Most probably tomorrow ;)

photo
1

Thanks again, since update it works like before :)

photo
1

Oki, fine :). Please just keep in mind, that this settings is on own risk and if there will be any issues because of this settings, I'll most probably won't be able to fix it.

photo
1

Hi Menion,


just updated. Works here as before too. If this new setting "All screen locks" works like the one before version 3.16.0, devices without issues wouldn't have such with it now. Do you have a link to some issues, People had with the old setting you disabled in version 3.16.0? Would be interesting to me.


Many thanks again

tkansgar

photo
1

Perfect, glad it works as before. Main issue was nicely describe for example here: http://help.locusmap.eu/topic/locus-pro-freezes-after-screen-offon

photo
1

Hi Menion,


thanks for the link. Seems it has to do with the screen lock method of some device producers. On my Samsung I never had any frozen input dialogs displayed by Locus. Hope this remains so.


tkansgar

photo
1

Yes I also think it is highly dependant on used lock screen and device manufacturer. Anyway as I wrote before, I hope all are now satisfied ;). Enjoy Locus and sunny days (at least in central Europe)

photo
photo
1

Hello,


The problem has reappeared for me on my new Moto G4. I can't disable the lock screen on this device. Any ideas?

photo
1

I have found it on today`s trip too :-(

Something has gone wrong again !!! :-( :-( :-(

photo
1

Good day Ulrich, Celda,

just testing and seems to work.


What kind of lock screen are you using and what settings do you have in Locus? If you use secured keyguard, then it's possible that it won't work. Only guarantee is this feature with un-secured keyguards.

photo
1

The same proglem also for me. I havent chaned any settings, and before update it worked. Sony Z1.

Disable lockscreen: Every locksceen

that what I choosed

photo
1

The issue seems to be intermittent. During navigation it works. After a restart of locus without navigation it does not...

I have not yet figured out a pattern...

photo
1

It looks like the disabled lockscree seems to work only after locus awoke by itself once:


Starting Locus: Disabling Lockscreen does not work.

Then I start Navigation: Still not working:

The first Navigation Instruction wakes the phone (display on).

Now lockscreen is disabled.

Stopping Navigation: Lockscreen still disabled.


Stopping & Starting Locus.

Lockscreen enabled again.....

photo
2

Aaaa got it. I'm really sorry. Tiny issue in one copy&paste operation.


Issue found and fixed. Unfortunately there is not possible workaround. You will have to wait on next Locus version. Sorry for this complication!

photo
photo
1

Unfortunately, I must use a secured VPN from my mobile to my company so my company wants me to keep the lock on (and even Android does not allow me to switch it off any more.) I use a gesture as the lock.


I can understand you do not guarantee Locus can overcome the lock in this case, however the point is IT DID WORK till the last Locus update so it means you WERE ABLE to do it for my mobile (Lenovo VIBE shot + Android 5.1). Try to revert this feature, please.

photo
1

Hello, I have this problem again like 4 months ago. After your solution, it worked fine like before but since the last update the lockscreen problem is back again... :( please help!


Sorry, just saw the other thread and your answer.... thanks again for fixing the problem!

photo
2

Yup. Same here with a MotoG and a Motog2 both on android 4.4.x and Locus 3.18.6. Using PIN unlock. Ok, we will wait for the next update.

photo
1

Hello, same on Android Lollypop, please promise to fix the problem, it is a very useful feature!

photo
1

Hi Menion,


today I determined, that I now have the lockscreen problem too. Everytime I switch on the display, I have to unlock it with my wipe pattern, although the Disable Screen Lock option is on. So my old question again: Could you say, when the next Locus Map version with the bug fix will be released?


But anyway: Locus Map is one of the best and most useful apps I ever had!


tkansgar

photo
1

Hi


Same problem on my Note 4 Android 6.1

photo
1

Good day guys, I'm really sorry for this new problem, unfortunately as I wrote above, currently there is now workaround and is needed to wait on next version where this problem will be fixed. Sorry for a complications.