Problem with maps bought in the locus store

Robert Marks shared this problem 2 years ago
Not a Problem

I have Locus pro 3.14.1 (German language) installed on a Samsung Galaxy S 5 mini with Android 4.4.2 From the Locus store I have downloaded two Swiss Topo maps and stored them locally. Everything was working well for some days. But now Locus shows an "Access denied" (Zugriff verweigert) message instead of the Swiss Topo maps. Other online maps and locally stored vector or raster maps are still working well. I have tried to reinstall the maps, but without any success ("problem with map".). The maps are stored on Locus/maps/swisstopo - hiking trails/mapname.sqlitedb and mapname.sqlitedb-journal. The maps are also listed in the map overview and they also show the correct region, which I can see, if I load an Openstreetmap, for exemple. But the Swiss Topo maps themselves (that means the display) are not shown.


Now I am unsure, wether I should buy more maps what I would do, because locus is a very good app. Thanks for your help.


Robert

Comments (4)

photo
1

Hi Robert,

are you logged in to locus store with same email adress you bought the swiss maps?

menu/Locus-Store/click top right to check

Wolfgang

photo
1

Hello Robert,

every download swisstopo map is locked only for the account that purchase this map in Locus store. For this reason is needed to check that you're logged with the same account you used to use when you purchased the problematic swisstopo map. Please check the account as balloni55 suggested. In case that you're logged with the same account please follow:

- open Android system settings > app manager > Locus Pro > click on Clear Data

- start Locus > Menu > Locus store

- Locus should shown dialog to select account you want to use in Locus store - please select the same account that you used for purchase of mentioned swisstopo map

- after that close the store and try the map


Please let me know about progress

Best regards

Petr

photo
1

Hello Wolfgang, hello Petr,


yes, that was it! I had added a new account and this one was activeted starting Swiss maps. Thanks for help and

Best regards


Robert

photo
1

Hello Robert,

thank you for info. I'm glad that issue is solved.

Best regards

Petr

photo