SQLitedb map "unknown error"

Tomek shared this problem 2 years ago
Not a Problem

I used this sqlite map one year ago (google hybrid sqlitedb map, about 900MB) and there was no problem with it. Yesterday I've put it into the map folder and after I've opened locus there was error message "unknown error". Only this one map have this problem, other works fine. I try to use another android device - still the same.

Next I've tried to use this solution:

http://docs.locusmap.eu/doku.php?id=manual:advanced:map_tools:corrupted_sqlite

but only first step is ok. After I make sql file (first command is ok, works), I try to use second command line but it return error message ("cant open file" or something like this..).

Any idea how to repair sqlite or how to convert sql to sqlite?

Comments (5)

photo
1

Hello Tomek,

I'm sorry but your maps is very likely broken. Any solution I can offer is mentioned manual page http://docs.locusmap.eu/doku.php?id=manual:advanced:map_tools:corrupted_sqlite


Please try the both steps again. Be sure that there is not typing error in name of file.

Best regards

Petr

photo
1

Thanks,


I try several times to use second line of command, no typing error for sure :-), but.... please let me know if it is correct what I mean:


sqlite3.exe -init name_of_map_dump.sql name_of_map_fixed.sqlitedb

name_of_map_dump.sql - it is map which was made in previous step

name_of_map_fixed.sqlitedb - any new name of new (fixed) file (???) which will be made in this step


Is this correct?

photo
photo
1

try to load your sqlitdb into MOBAC and see what happend.

part of file loading is descripted by user brotbuexe:

http://docs_old.locusmap.eu/doku.php?id=manual:map_tools:splitting_sqlitedb

photo
1

Solved.


I make this operations on SD card (in laptop build card reader). So I moved files to hard disk and after this there wasn't previous error ("attemp to write a readonly database"), there was new one error:

"unique constraint failed"

I make changes in files permission and it runs! New file was created.

Import to Locus without any problems.

photo
1

Great I also though that can be something with writing permission.

I'm glad it's solved