Strange guiding behavior on certain tracks ...

Kriss shared this problem 6 years ago
Solved

I tested locus pro deeper today and I found a strange kind of guiding on certain tracks.


Imagine a track like you see in the uploaded picture.


My tracks goes from point #1 to point #11 passing via point #7.


When I let Locus guide me, It will switch automatically from point #5 to point #10 If dont turn to #6 from myself if don`t pay attention.


The problem is that I rely on Locus to prevent me when I`m out of the way and so I did not look systematically on the screen. (Beep on distance when too far away from track)


My configuration is this one.


In the Guiding Menu=> Tracks:


Guiding sounds => checked


Set next point 40m


Play sound when too far away from track


Beep checked


DISTANCE = 25m


It seems it reacts like it will alway try to search "the nearest point" to guide on !


Is there an option to be possible to always follow all the trackpoints ?


I use Locus Pro 2.0.1 on Android 2.3.4.


Regards,


Chris

Comments (13)

photo
0

Hi here is some news.


Today I restored Locus pro Version 1.8.9 with the same parameters ( next point 40m) and the same track and this version works like a charm :)


Every trackpoint are guided like I wanted (40m switch) and when I miss a turn an alert is raised . Everything I need :-)


Could you bring back this guiding algorithm in the next versions ?


Thx,


Chris

photo
0

From a programmer point of view its very scary to think what else could be lost. I recently spoke with creator of mapc2mapc, because I discovered, he introduced a bug in bitmap shrinking algorithm. "it was now combining y and y+1 when it should have been combining x and x+1".

photo
0

Hello after searching solutions on the locus forum, I think I know where the problem comes from.


You `ll have to simply read this topic Locus Forum - Track guiding: manual force jump to next point


And what I suspected seems to be true: auto-nearest function is always enable since version 1.13.2 !


And I also understand this is the same root cause as my other problem report here Locus automatically reverse the guiding sense on certain tracks !


Ok maybe it is very useful when we are driving in a car but when hiking we must be able to deactivate this function :/ ?


Thx,


Chris

photo
0

Let`s assume a river between point 5 and 9 and a bridge at 7. It is not helpful if Locus tells next point after 5 is 9 or 10.

photo
0

tommi, it`s not that case.


Locus algorithm for best point selection works well I think. If there will be river, you`ll have to turn along the river. Locus do not switch on opposite side because you`ll have different bearing and also between you and opposite site will be some distance.


Anyway truth is that exist situation when this behaviour is not wanted. I can imagine situation when I ride bike along path and have defined branch on some castle and by same way back. In this case, current algorithm take next point along path and skip branch.


So I accept this as a problem and I added ability to disable automatic switch on best point. Because I believe that current system is working and more then 95% of time, fits best user experience, I`ll set it enabled by default

photo
0

Thanks Menion I appreciate your job and devotion ;)


Locus is the best app for hiking.


Regards,


Chris

photo
0

you`re welcome, but rather thanks after you test new update ;)

photo
0

I can see that your choice for Set next point is 40 m


Have you tried to decrease it? I think you can decrease it down to 6m


Just wondering ;-)


Cheers


zailor

photo
0

Menion wrote: "So I accept this as a problem and I added ability to disable automatic switch on best point." I think this is the solution...

photo
0

guys, did you tried new settings "Auto-select best point" in Guiding settings screen? (it`s possible to test it also at hope just with moving with center cross on map). This should be working solution on this issue, so let me know if it works and is enough ... thanks

photo
0

Hi Menion, I didnt know that correction was implemented in the 2.1.1 version because the releases notes say nothing about that.


I installed it and play with the simulation mode and it works very well.


This week end I would be able to test it outdoor.


Thanks for the effort :)

photo
0

Kriss, may you give me some feedback? Or still testing?


Same for this topic https://getsatisfaction.com/locus/top...

photo
0

Hello Menion, thanks yes it is working now you can set this topic as Solved ;)


But I have detected another problem I will open a new Topic.


Regards,


Kriss