Watch Errors with Bluetooth

erickson shared this question 22 days ago
In Progress

I just bought the TicWatch 3 Pro GPS. Unfortunately I get a message that Bluetooth has been lost and to check Bluetooth settings. Both my phone and the watch show a good connection and other apps do not have a problem. I tried reinstalling the watch app, resetting Bluetooth, and the like. Is there a solution to be able to have my favorite app on my favorite watch.

Comments (6)

photo
1

I should mention that I disabled battery saving mode.

photo
1

Hello Erickson,

please check the battery optimization settings.

If the problem persists, contact us.


Have a nice day Andrea

photo
1

I had checked battery settings, reinstalled Locus on the phone, reinstalled it on the watch, reset network connections on the phone, rechecked settings in Locus . . . Finally I decided to try the nuclear option and wiped the phone with a complete factory settings restore. That seems to have worked.

photo
1

Although it appears I have spoken too soon. Without changing anything, the next time I started Locus, I again goy the message that the connection was lost and to check Bluetooth settings. I tried restarting the watch and reinstalling Locus on the watch. Back up square one.

photo
1

I tried a few more things on the phone but for now things seem to be working if I restart the phone just before I want to use the app on the watch. Since I usually only use Locus Watch to keep track of things on hikes or with geocaching it’s not that hard to restart from time ti time.

photo
1

Hello Erickson,

please make sure optimization is turned off for both Locus and Wear OS by Google Smartwatch.

Take a look at the link on our site.

I hope your problem is resolved.

Have a nice day

Andrea