How do I make Locus use the eurotunnel instead of ferries when navigating

Jeffrey Penna shared this question 12 months ago
Answered

If I navigate to a destination from England to else where in Europe Locu always chooses to route via ferry but I always want to use the channel tunnel.

how do I specify no ferries?

Replies (5)

photo
1

Hello Jeffrey,

I can't simulate your problem, can you please send me more information, including a screenshot.

However, try to check if you have GraphHopper - navigation data source set, in Route planner> Drawing mode> Car> and if you select Settings, you can check Avoid ferries.

Perhaps this information will help you, otherwise send a screenshot and details.

Have a nice day

Andrea

photo
1

Thank you for your reply.

I've attempted to give more information in the attached file.

As I say in the file, it seems like Locus has no knowledge of the Channel Tunnel existing for navigation purposes and will always use ferries.

photo
1

Hi Jeffrey,

Locus Map uses third party routing services for generating routes for navigation or planning. In this case, both BRouter and GraphHopper have problem with using the LaManche tunnel:

- BRouter - all its profiles, unfortunately, ignore the tunnel

- GraphHopper - "car" profile uses the tunnel but the "avoid ferries" must stay unchecked (!)

We'll investigate the issue more deeply to find out if we can do anything about it. Thank you for reporting this problem.

best regards

Michal Stupka, Locus team

photo
1

Thank you for your response

I'll just have to create 2 navigations when needed

One to a destination very close to the Channel tunnel

and

one from a position very close to the tunnel to wherever I need to go next.

Jeff

photo
1

Hi Jeffrey,

we are sorry but for now, we don't have solution of this trouble. As for the BRouter, it is now an external app with their own profiles. When we build the router inside Locus in the version 4 (which is actually done) and we will tune our own profiles, we'll take this into account. As for the GraphHopper, our code is OK so the bug must be elsewhere again.

Leave a Comment
 
Attach a file