CRS:84 not showing up as CRS choice in WMS

Jānis shared this problem 3 months ago
Solved

Hello,

First of all apologies if I get any terminology wrong, only recently discovered about WMS / different coordinate systems :)

So my problem is with this public WMS service. It gets imported just fine, but unfortunately overlays are all messed up, there is an offset as you can see in screenshot #1. As I understand problem lies that this WMS service is using a local nonstandard coordinate system (EPSG:3059) and Locus works differently (EPSG:4326 only?). I added this system to Locus as per this guide, but WMS overlay position did not change. Probably that's expected since guide mentions that it's only for displaying coordinates.


In screenshot #2 it can be seen that only EPSG:3059 can be chosen, but when I check WMS configuration file it also lists CRS:84 which as I understand is the same as standard EPSG:4326 but with reversed axis. Is it currently expected that CRS:84 is not supported and is there any reason why it's not included in Locus?


This problematic WMS shows layers correctly in Google Earth and 1 WMS specific Android app I tried so it's config file should have correct syntax.

Comments (1)

photo
2

Hello Janis,

thank you for the precise bug-report. Indeed, the issue found in Locus Map itself. Problem found and solved. Will be working as expected in the next 3.50+ version.

Jiří M. aka Menion

photo
1

Thank you Jiří for a swift resolution, really appreciate it.

photo