Persisting intialization malfunction of Locus Pro 3.50.1 (summary of my previous 3 topics)

dasilva shared this problem 4 months ago
Solved

Dear Menion

I am a new user of Locus Pro, and purchased the Pro version because the Free version was stable and functioned without any problems.

Unfortunatelly, the Pro version (3.50.1) is not stable and does not function correctly on the same (android 5.0.1) device that had to trouble with the Free version. All in all, I am having a hard time to understand why the pro Version is less stable than the Free version, and ask myself if this may be a bug on the 3.50.1 version of Locus Pro...

Assuming that the problem that I am experiencing can be solved with your help, I decided to summarize the malfunction issue in this topic, and hope a lot for a solution.

Here the summary:

- Initially, downloading a map >2GB did not work with the SD-card in FAT32 format. So after writing a topic on it, I formatted the SD-card to exFAT based upon the information on the database.

- After that, upon initialization of Locus Pro 3.50.1, “unknown problem : Can‘t find the map“ was displayed. I thought it had to do with the exFAT format of the SD-card, and wrote a topic on the theme “unknown problem“. Then, after resetting Locus Pro, “unknown problem : Can‘t find the map“ diappeared, so I happily added „Solved“ to the title of the topic.

- I should have waited, because the initialization malfunction and “unknown problem : Can‘t find the map“ returned shortly thereafter. Hence, I wrote a new topic about the recurring issue.

- After deinstalling and reinstalling Locus Pro (Version 3.50.1) from GooglePlay, “unknown problem : Can‘t find the map“ shortly dissapeared once more. At the same time, after a long "loading" latency, „connection failed“ appears on the constantly empty (gray) screen – no map whatsoever. Also. to make things worse, besides no display of the initial map screen, the "unknown problem : Can‘t find the map“ message reappeared during initialization. So I wrote a comment mentioning this, and included it in the topic.

Along this series of events, a total of 3 bug reports were mailed to locus.map(at)asamm.com


Meanwhile, assuming a connection problem of Locus Pro 3.50.1 to GooglePlay service. I also cleaned the GooglePlay data on the device settings. But the initialization malfunction of Locus Pro 3.50.1 still persists, despite of flawless internet connection and perfect function of all other apps installed in the android device (Samsung GT-I9506).

At present, this whole issue has significantly curbed my enthusiasm for Locus Map. So I would really appreciate your help, and hope that my Locus Pro will soon function appropriately.


Cheers

Comments (3)

photo
1

Hello dasilva,

I'm not an expert on SD cards and formats of file systems. I remember, there was a limitation on how files can be on the FAT32 formatted card (probably a little less than 4GB). What issue are you exactly facing with the latest 3.50 version of the Locus Map app? I miss a more precise description of your problem.

photo
1

Hello Menion, thanks for answering.


After formatting the sc-card, i got

“unknown problem : Can‘t find the map“, so I wrote a topic on it.


At first the „unknown problem“ seemed to be gone, but I was mistaken.


Because of the persisting issue, I then deinstalled Locus Pro and installed it again (Version 3.50.1)

Since the reinstallation „unknown problem“ apoears to be gone, but there is still malfunction.


Now, after a long loading time, the usual (online) map is not loaded to the start screen, and then „connection failed“ appears where „loading“ was.

I also wrote a topic mentioning this.


Altogether I mailed 3 report bugs via e-mail.


I am a new user and this whole issue is getting me quite disappointed with Locus Pro.


Your help would be very appreciated.

photo
1

P.S.:

I only purchased the Pro because of the Free version made such stable ang well functioning impression.

It‘s hard to believe that the pro Version is less stable than the Free version....

photo
1

Have you tried making sre that all of the locus directores are using the internal SD card location not the fat32 external card.

Have you tried without any external maps, as in just the base locus installation.

Old versions of android can get very flaky, especially with external sd cards,

photo
photo
1

Hello Locus Pro team, dear Menion, I have an update:


After resetting Locus Pro 3.50.1 , now the “unknown problem : Can‘t find the map“ does not appear.

That fells good for a starter.


During first start, the screen displayed "OSM- Outdoors - Hiking, Bike", a non downloadable map. Since my intended use of Locus Pro was and is to use free downloadable maps with a large daily download limit, I then accessed the map manager and selected the map OSM-Outdoor - MTB Europe, which I previously used with Locus Free (including downloads), and it functioned just fine.

At present, when OSM-Outdoor - MTB Europe is selected via map manager, it cannot be loaded. If I do not change the selection to another map, every initialization of Locus Pro 3.50.1 starts with a long "loading" latency, and then „connection failed“ appears on the blank (gray) screen, as previously reported (see above).

So, as of now, I suppose that the main issue concerns my Locus Pro 3.50.1 not being able to load OSM-Outdoor - MTB Europe, which - as far as my knowledge of the Locus map database goes - seems to be THE free downloadable cycling map with a high (50k units) daily download limit, and hence my number 1 preference for the intended use (I commute by bike in different directions in a region where the cycling paths are not well known to me).

Supposing - and very much also hoping - that the "unknown problem" previously reported dos not return, my present (or updated) issue can be summarized in the following question:

- What can be done to restore the abality of Locus Pro 3.50.1 as to loading (and downloading, and storing, and also reproducing any stored segments of) the map OSM-Outdoor - MTB Europe ?

photo
1

Hello dasilva,

firstly, sorry to read you have such problems with the Pro version of the Locus Map. It is surprising that the Pro version works differently because they are (almost) identical (share same source code).

I'm analyzing your logs and from what I see, there

a) is any problem with "/storage/emulated/0/Locus/maps/SLR 100km Radius.sqlitedb" file. App has a problem with loading it's content (map bound for zoom level 9). If it's possible to share this file with me, I may look at it.

b) is same problem with the map "/storage/extSdCard/Android/data/menion.android.locus.pro/files/mapsExt/SLR Radius100.sqlitedb". App on read-only SD card should work as well. It is the same map like in previous case right?

Because you have the "Locus" directory in the root of internal memory, Locus Map Free and Locus Map Pro share the same data (same maps, points, tracks, ...), so the same issue has to happen also for the Locus Map Free.

---

So for me, it looks like the only problem is with the mentioned map. Remove it, send it to me for analysis or redownload it. It should help.

Regards "MTB Europe" maps > they have from time to time technical problems. It is a hobby project hosted on the University servers. Suggest giving a try to vector maps (LoMaps, OpenAndroMaps, ...). Maybe for some reason, also your cache for these online maps may have some problems. You may try to clear it over MTB Europe map > context menu > clear cache.

Hope this helps.

Menion

photo
1

Hi Menion, and thank you for your reply.

Since you wrote, I have completely deleted the map that seemed to be broken, reinstalled LocusPro once more, and - for some magical reason - about 10 days ago it started working as if nothing happened before.

That is a reason to be satisfied :-)

I am presently experiencing another issue with navigation. Since that is a completely different topic, I will create a new entry about it. And hope that there is a simple solution to it...

Thanks for the great work with LocusMaps.

Best regards

photo
1

Hello dasilva,

I'm glad to read that problems are solved now, perfect. Problems that disappear for some "magical reason", so they can't be easily repeated/simulated are almost the worst one.

Hope, you won't have no longer any similar issues.

Have a nice weekend.

photo